Harmony Home Control

ST support got back to me stating that the update doesn’t fix integration and that they will get back to me when the issue is resolved.

Ouch! But thanks for letting us know.

It’s interesting that you say SmartThings can’t find Harmony. I never had to add Harmony to SmartThings from the SmartThings app. My Harmony Hubs showed up in SmartThings after adding SmartThings in the Harmony app. No action was necessary in the SmartThings app to setup my hubs. Given the number of complaints in this thread, I’m hesitant to attempt to repro the issue since has been working for quite a while.

This is why I keep mentioning that “Perhaps I am linking them wrong.” It’s not documented anywhere how you are supposed to link them. Harmony only mentions adding ST to the Harmony app but they seem to only care that you can launch a ST action from the Harmony remote. What I want is to be able to Automate Harmony actions from ST which seems to be done from the ST app.

What are you doing with the integration. Are you having ST launch any Harmony Actions or are you having the Harmony control devices connected to ST ? The later seems to be working for folks but I have not tried because I don’t have any ST devices that would make much sense to control. I don’t really need my Garage Door opened when I start playing a movie :smile:

I got the home control version a few weeks ago. Controlling ST from harmony works great but haven’t been able to go the other way. ST Never finds the hub

All I had to do was add SmartThings in the Harmony app and that created the Logitech Harmony Connect app and the Harmony Hub devices in SmartThings automatically. After that was done, I added instances of the Logitech Harmony Hub Control app to power off my TVs when everyone leaves.

I originally had Harmony controlling some physical devices in SmartThings, but I wanted to be able to do different things during the day vs. night, so I am now using Harmony to flip a virtual switch in SmartThings. I use that virtual switch as a trigger to do different things based on the current SmartThings mode.

The Harmony Connect app doesn’t poll the hubs automatically because the hub device types don’t have the polling capability. This means that it won’t automatically show the current activity without hitting refresh. I am using Pollster to automatically refresh the current activity for me. I don’t use the current activity as a trigger for anything in SmartThings, but it’s nice to see the activity log which shows when the TV was turned on and off.

Honestly, while my integration is working, it is very disappointing that you can only control activities via the integration. I would much rather have the ability to send any command to any device without affecting the current activity.

@Ron, I should point out that within the Harmony App I always get an “authorization failed” message when doing the authorization step on the ST aught page. Yet it still works. I also use virtual switches to turn on Harmon actions that control my TV/media. Hope that helps.

@April, @Ben,

Are SmartThings able to shed some light on this? This problem has been ongoing for quite some time now. Whilst the fix may require an update from Logitech (still unclear), are you able to state whether you’ve identified the underlying cause and what will be required to resolve this?

If the cause and fix are at least known it may save a lot of people here time and angst trying to fix something which may well be beyond their control.

Official news from both SmartThings and Logitech has been very scarce and very non-committal to date.

1 Like

Yes, it adds the connect app for permissions, however you cannot initiate actions FROM ST, only Harmony. I am using virtual switches too but there is certain functionally that you need ST initiation for such as powering on tv when arriving home.

Once I go through all the steps, I have the Logitech Harmony Connect app installed in labs. When I open it, it starts trying to find the harmony hub, but doesn’t

Then, I go in and attempt ton install Harmony Hub Control. It asks me to select my Harmony Hub. When I tap on Logitech Harmony Hub - Tap to Set, my only option is to connect new. When I tap the plus to connect to, it looks for a media controller but never finds one. It will not let me go any further at that point, because selecting the hub is a required field

Logitech confirmed that they broke their API with a firmware update but that was Dec 22 and still no fix

Here is the latest direction to resolve the issue from Logitech, which mind you did not work for me…

Eric, after coordinating with our higher technicians, we would like you to reset your router if you haven’t done so and check if it would resolve the issue.

If the issue persists, let us update firmware on your remote following the steps below:

  1. Launch MyHarmony Computer Application
  2. Before clicking inside the window, Open advanced tools page by the key combination below:
    –> Windows users: Press Alt+F9
    –> Mac users: Press Fn+Option+F9 or Option+F9 (depending on Mac model, either one will work)
  3. Select ‘Update Firmware’ button under Harmony Home Control
  4. Follow the steps in the tool to install the firmware manually
  5. Once you are done, click ‘Return to login screen’, open your MyHarmony account and make a USB Sync

Please let me know the outcome.

This tech sounds like he has absolutely no clue that this is a known issue and is giving you the standard support response. This shows how little Logitech thinks of the problem as their support staff isn’t even aware it’s a problem.

I escalated through the Logitech twitter account and sent them the link to this thread and others on their own forum. Supposedly they escalated to their management. We’ll see.

Trust me they aint doing anything to fix this. They released a new firmware last week and it still hasn’t been fixed.

@Ben @April

Whats the status of this Harmony issues? I mean it hasn’t worked since Nov for new users trying to integrate it with their ST’s . Think its about time to either get it resolved or remove it from your “Works with SmartThings” list:

1 Like

Is there anyway to downgrade the hub/remote firmware to one that works with ST?

I don’t think there is a way, but you would have to contact Logitech support for that one…

Hey guys,

Since this seems to be the thread… remember when the Harmony Home Control came out and Logitech mentioned that there will be a (paid) firmware update for those of us who bought the “Smart Control” product to allow us to use some of the Home Control features? Is there any news on this? I hope it’s out and I missed it…


Not out yet. I gave up and sold my smart control on eBay and bought s home control unit.

I would doubt it. The firmware updates every time you sync if it isn’t current so a downgrade would upgrade on the next sync. But @Mbhforum is correct you really need to contact Harmony Support for this one. If you do and they tell you a way please share.