Hard Reset Hub No Longer Showing Any Devices

I had to add a new hub to my location. Once I did, I still see all of the old ones but they are all showing as “Offline”. I have re-added the hub a few times and with the same results. How do I get these to activate on the new hub?

Did you reset and re-onboard the devices to the new hub? Unfortunately they don’t join the new hub automatically.

1 Like

How do I re-onboard? Would I have to take the switches out of the wall to re-scan the QR code? That seems crazy as the app appears to have the unique ID for each already in there. I can still see those items in my location along with the new hub but I they all show as “offline”.

zigbee and zwave devices are managed by the coordinator on the hub itself. So what you see stored in the cloud is old data from your old hub. You shouldn’t have to remove wall switches, but you will have to take off the face plate so you can scan it when re-onboarding.

Yikes! I have dozens of them. Wow, that is really, really unfortunate. On top of that I have dozens more macros that call those devices (timers, etc). So I would have to reset the entire house both from devices and macros? This seems very labor-intensive for simply swapping out a hub. Is there really no other option?

Sorry, add-on here… do I essentially have to re-add as though I have never added before? If I then add as the exact same name will it give me a conflict with the old one with the same name? Last, if I can make the same name, would that at least keep the macros and whatnot in tact or do those things get called by a unique ID on the back end that I can’t see and would then require that to be re-done too?

Can you provide the full back story for what you did? You mentioned a new hub… was that a replacement hub or a second hub being added along with your first hub? You mentioned hard reset in the title… was that for the original hub in the location or for the new hub? Why did you perform the hard reset? Just trying to figure what is going on?

Apologies, that would be clearer yes. So we got a new router from our internet provider. When we rebooted all things the hub just blinked blue. Swapping out cables, cords, ports didn’t fix it. Unblocked all ports, same. The only thing that fixed it was hard resetting the hub itself. When it did its reboot, while that too took 3 or 4 tries to get it to finish, it finally did. At that point, I added the “new” hub to the network and all was fine. I saw the old devices there and all was fine. That is how we got here though. So technically this is the same hub, just reset.

Yikes! Here is where I mention a soft reboot of the hub (unless you tried that) might have fixed that issue without the need of a hard reset. So to verify: with a soft reset: you power down the hub by removing power cord, while pressing the reset button you plug the power cord back in. When you see the flashing yellow with the hub led, you release the reset button. Soft reset wipes out the existing network settings and starts fresh and attempts to contact ST servers but all devices and Routines remain intact. A hard reset follows the same procedure except you continue pressing the reset until the led light changes to a solid yellow. Once a hard reset occurs, you basically start from scratch… add devices back to hub and redo all your Routines.

If you add a new hub: there is a utility to migrate from the old hub to new hub but can’t be dome from a reset hub (dead hub is possible I believe but not a reset one)

now that you have performed a hard reset… as mentioned, you get to add the existing devices back (exclude z-wave devices and reset zigbee by removing battery or pressing buttons - check the guide for them). On-boarding … I will let others speak on that. I don’t believe you can edit Routines and add the new devices back so I am pretty sure you need to start fresh. Others might know.

Wait now… I did the thing you are calling a soft reset. Power cord out, paper clip in, wait for solid yellow, remove paper clip, allow reboot. Does this change my outlook?

You wrote solid yellow… that is a hard reset. Flashing yellow is soft reset.

Well ok then. So I have to then re-add these things and then do what with the old ones that are of the same name? This feels like it is not going to work due to that. Just trying to do this as efficiently as possible. This feels like there should have been an easier way to do this is all. I have been making software for 25 years and I am struggling to understand the mechanics here. I have no idea why the original problem occurred and I did multiple times what I thought was a soft reset and nothing worked. This was a multi-day project. I am disappointed that the controller is not the app itself or that a copy of that script does not exist on the app as a failsafe for such occurrences. This will likely take multple hours over multiple days to pull off if this is right. That seems absurd when this is not a necessary outcome. That all said, thanks for the assistance. This feels very counterintuitive so happy to have any feedback on this.

I think many wonder the same thing. It appears to happen to a few users every month.

The whole reset is not a fun process especially if you have many devices and Routines.

Here are some troubleshooting tips (some of this page is out-of-date in terms of references to the old IDE. This info works across all hubs.

1 Like

Appreciate that. Just out of curiosity, had I gone the soft reset route, how would that have changed the outlook here? Was there a method to export old → new?

not going to sugarcoat this… the soft reset may or may not have resolved the issue. Different methods resolve the issue for different user setups. It has worked for some but not all. Others have found different methods to get it to work for them… rebooting the router/ST hub; others have made configuration changes on their router. The reason I like mentioning soft over a hard reset is that you are only resetting the network configuration of the hub and you do not need to go through the hassle of rebuilding everything from scratch when choosing the hard reset.

There is a migration tool in Advanced Web App. Go to the hubs section and tap on the new hub name. There should be an option to migrate. It can also be performed from the ST app by opening the new hub tile and tapping on 3 dots. The tool is only available when you have multiple hubs.

It is a rather new tool and I have not seen any users post details on their experiences or the process.


Thank you again for the help. Looks like I just have to roll up my sleeves and get er done. Question - once I re-do this all and get it set back up (many moons into the future at this point) can I make a backup somehow so that if I have to get another hub, or this one craps out again, I can just “restore from backup” kind of thing?

unfortunately not at this time. However, there’s a topic on hub-replacement next week at SDC, so things might change.

1 Like