Hangar Hub Continuously Offline

I have a V2 hub connected to a Netgear cellular modem at my aircraft hangar. I use it to control power plugs for turning on the aircraft engine preheater the night before I go fly. It has worked pretty well this winter. Lately, my Smartthings App is showing the Hub offline and I can’t access the plugs either, obviously. The Netgear modem is showing 5 green bars indicating strong signal coverage. Any ideas why I can’t access my hub? I tried pulling the power plug and taking batteries out for a few minutes, but it never comes up on the IDE or the app.

Hey there @Pacman45,

Let’s first take a look at the behavior of your LED Indicator. What color is the LED indicator? Is it Steady Solid or Blinking?

Here’s a troubleshooting article for the Colors of the LED Indicator: LED Indicator on the Wi-Fi and SmartThings Hub

Do you have your hub connected using Wifi withing range of Router or Connected via Ethernet?

Sorry for the long delay. This issue was resolved when I discovered the ethernet cable that was supposed to be connected directly to the cellular modem, was instead connected to a disconnected router. Problem resolved.