Hampton Bay Zigbee Fan controller

Hello Dalec thanks so much for your work on this controller. I am new to SmartThings and I finally got my parts through Home Depot yesterday. I installed the unit and did the Github connection and tried as best as I could to install it I SmartThings. I got the unit paired but on mines it shows the fan speeds as fans but when I activate them it says adjusting and that’s it the main screen shows it always at max speed and there is no slider on the bottom to adjust the brightness of the bulb. Also the system seems to be activating itself so I’m not sure what I missed and I was hoping you could maybe point me in the right direction as far as troubleshooting it. Your assistance would be greatly appreciated

See here fareedbaksh;

An update to smartthings messed something up, fix is in the link

Thank you so much DomSim I am new to all of this so I’ll try to figure the editing and post a reply, thanks again for your help.

1 Like

Here’s what I did, which worked. Added /* before the lines and */ after the lines 363 and 370.

1 Like

You could simply just put a double slash // before anything on a line that you want to comment out.

Adding /* and */ is generally only used when commenting out multiple lines and isn’t required on a single line.

1 Like

Thanks! Wasn’t sure. Single slash didn’t comment out the whole line, but looking through the rest of the code, I saw the asterisk + slash and it commented out the whole line. Any problem leaving it as is?

Nah, you’re good. Just an FYI to make things easier in the future.

1 Like

Hello again DomSim I tried adding the /* at the both lines and this is the error I got when trying to save it
org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
script_dth_metadata_9c711a28_8125_4cf1_8b4a_71f7b66d6809: 405: expecting ‘*’, found ‘’ @ line 405, column 2.

It should be a double slash in front of both lines.

Thanks stephack I did that and it took the error away, unfortunately I am still stuck with the fan interface not updating when a fan is clicked on (the fan speeds don’t show up it just shows a fan symbol) and there is no dimmer line that allows me to dim the light or be able to reflect the speed in the main interface of the fan controller

This is what it looks like when I click on a fan speed

The line at the bottom is no longer part of any device. Smartthings updated their interface a while back. The “99%” in the lower right of the main tile is where u click to adjust the brightness now.

Is the fan speed actually changing?

Yes it does but it does not tell me what speed it’s running nor does it show up in the main interface it just stays on high regardless of the speed I chose plus it shows as on under my things even if it’s off see the image of what my things show

Is it possible you commented out more than just the 2 lines indicated?

Otherwise place post the log output when you tap one of the speed controls.

Don’t think so, how do I go about posting the log, thanks in advance.

There is a Live Logging link at the top menu of the IDE. Another thing to try is to cycle through the fans speeds and light levels using the remote control (if u have one).

Thanks will give that a try and follow up. I have it connected to the Github repository do you think that could be an issue

Nope. If you pull it from github and then edit it, it will work fine…as long as you don’t “update from repo” because that will undo all your edits.

After editing the DTH did you save AND publish it. If you don’t publish it, it won’t update to the app.

I’d say you could also post a screen shot like I did, to make sure the edit is correct.