Hampton Bay Zigbee Fan controller

Back in stock; just bought two.

UPDATE: [Installed it and everything went well](Sharing a success story: Successful Hampton Bay Ceiling Fan Installation)


That monster thread confuses me.

I have a Hampton bay fan with remote control.

The electrician installed a dumb stack switch on wall to control. Top toggle controls fan (on/off only), the remote controls fan speed. The bottom toggle controls the lights on/off, the remote light button is disabled, since the wall switch & fan is wired to have only wall switch control the Light.

So if I buy this zigbee fan controller, I have no idea where to begin.

I pulled the trigger & ordered… this should be fun, I’ll be back here if I get stuck. Thx in advance


If your fan is not in the same room and close to your hub you might want to order a zigbee repeater if you don’t already have one. It will save you a lot of headaches.

1 Like

Sylvania Zigbee plug is only $15 right now.

Some version seem to repeat, others might not?

Interesting. I just received 2 in the new Smart+ packaging. I’ll double check when I get home.

I had the same recollection and checked that conversation after reading @bradlee_s post; it looks like the conclusion was that they both repeat but Xiaomi devices are a pain.

1 Like

I have ST smart plug, that I believe is a repeater

1 Like

My fan originally came with 3 speeds, as you know my original remote buttons were wrong, when pressed (meduim was high & high was actually med).

The new remote has 4 speeds (fan only originally came with low, med, high), so that already isn’t adding up…

Finalized setup, pairing was super easy! Added the 3 device handlers & done.

Final result is that I low is low, meduim is medium, medium-High is HIGH, & high is medium! Ughh why??!

Lastly I went to Alexa added ONLY the “medium-high (actually HIGH)” & Light… renamed them to “fan” & light”. So by voice it will work great… but it shows up on ST as medium-high & the remote will always require bunch of presses to get to the right fan setting, Sadly the remote doesn’t have a single fan on/of button.

I used the KOF device handlers… but my fan originally has 3 speeds & as you can see on my post above this one… I’m Running into issues with 4 speed setup… do you have a handler that could help me with my issue?

@dalec isn’t around much these days, I think he’s moved on from ST. In any case, there’s only one handler and it works pretty well so the issue is likely specific to your setup.

The number of speeds each controller has shouldn’t matter, and anything that was odd about your old controller shouldn’t affect this controller since you’ve removed that one. You set the pull chain on your fan to the highest speed (or the highest speed you want to use), and the controller adjusts the frequency of the AC voltage it’s supplying in order to control the motor speed. This is how the number of speeds can be different with a new controller, it just adds an extra frequency option in between medium and high. If your fan speeds are out of sequence that seems pretty unusual and it’s not obvious to me what would cause that.

If this is truly the case (and can’t be corrected) probably the only solution available is to modify the device handler to swap the speeds around.


Hi mark, my fan doesn’t have pull chains, speed are only controlled using remote. speeds where out of sequence with my old reciever/remote…as well, as mentioned.

When I setup new zigbee reciever/remote… using my old remote I set the speed to high (by pressing the medium button!)… then I cut power & installed new receiver.

So if both receivers (old one & new one) are mixing up medium with high… could we then assume the Fan itself is the problem?? Could somehow the internal fan motor be messed up?

This is beyond my area of comfort, I have no idea why both the new and old controllers would run the speed incorrectly. I guess it could be something unusual about how the motor is constructed but I can’t answer with any confidence. Sorry…

1 Like

I got the same response from Hampton bay tech support today.

Just now I added the wall mounted 3 speed control… that remote is also wacky with my fan… low is medium, medium is high, & high is medium!

Unreal I’m the only person on planet earth with this issue. Guess I should feel special.

Tech support said issue could only be with the receiver, since it’s the only thing that controls fan speed, because my fan wasn’t designed with pull chains. But I’ve tried 2 receivers & 3 remotes now… same issue.

Only thing i could try is getting a fan with pull chains to see if the remotes magically control fan speeds in correct sequence.

1 Like

This controller gave wacky results for me when in certain dip switch settings. From the remote, it would turn the lights on/off when switching to different speeds. Changing the dips completely corrected this. Give it a try!

1 Like

I’m surprised the tech didn’t mention this! I’ll certainly give this a try this weekend. So there are 6 dip switches, all are on the up position, should I lower 1 down?

Try lowering #1 2 and 3. I’m pretty sure that is working for me on at least 1 unit. make sure the controller and remote match.

1 Like

Posted this to another thread but not sure if that one is still active…

I setup 2 of the Hampton Bay controllers. They both work fine with the remote controls. They pair to the app, I can see them on the web and change the controller to the KOF Zigbee Fan Controller type (I tried the Github integration and also tried copying / pasting into my own repo), but the child devices never show up. My screen looks like this:

I’ve done the delete device stuff on the settings screen, but it doesn’t change anything. I don’t have any apps associated to it (deleted the Alexa app so it would update). The app doesn’t really do much, sometimes if I mess with it enough it will adjust the lights, sometimes it will turn off the fan (if it was on) but overall it’s not working, not to mention most of the buttons are missing. I’m using iOS ST app. It shows connected in the ST web app.

The remote works perfectly. All functions, even dimming work over the remote. All my other ST devices work as well. I even tried adding a Sylvania Smart Plug as a repeater in case that was an issue but it made no difference. I have 3 of these controllers and they all have the identical issue.

I have no doubt I messed up something, but not sure what. Any ideas what I could do from here to troubleshoot?

Thanks in advance!

Maybe an overly basic question - did you create all three device handlers in the IDE?