Halo Smoke Detector Lights Won't Stay On


#1

Hello. I’m new to Smartthings so maybe I’m doing something wrong. I just installed a bunch of Halo smoke detectors and one feature they have are LED lights that can be switched on via Smartthings hub. I set the Good Night routine to switch on the LED lights in the detectors as sunset, and the Good Morning routine to switch those same lights off.

The lights come on at the right time however after 20 minutes they all switch off. There are no notifications that would explain why that happened. Any ideas?


#2

I believe I read somewhere that this is the default behavior of the Halo smoke detectors. A comment was made that they were looking at making a firmware update to change this.


#3

I figured it was something like that. The update would be cool.

Thanks for fast response!


#4

Found this thread after seeing the same issue. Thought I’d update here to say this hasn’t been fixed yet. Really wanted the led as a nightlight on an automated schedule. I can theorize that it’s because the led is used by the sensors to turn on when smoke/co levels are elevated but perhaps not a threat yet, so it’s overriding the Smartthings command. Total assumption though.

Also, I find the temp is lower than my thermostat even though it’s nearly directly above it. Makes me assume the humidity is incorrect also.


(Matthew Valeri) #5

I use them as a nightlight via WebCore. They stay on for 30 minutes. I created a “rule” stating that between 2300 and 0200 if Smoke Detector turns off, turn on.

I believe the behavior is like this because the temperature reading increases with the led’s on. With the led’s on, the temperature reads between 83-90 degrees. Not an issue for me, but if you are using the temperature as a trigger for other things it would cause an issue.


(Ian) #6

Bumping this one back up to see if any updates have been made. I have the same timout issue. I don’t use the unit for temp reading so its tough to hear that may be the issue.

My goal is to have the light say on if SHM is set to Stay. It would make the perfect indicator for me since I don’t have a keypad and would double as a nightlight.

UPDATE: looks like I solved my issues in CORE…