Guestproof dimmer solution?


#1

Often after we have guests over, I’ll find our bathroom GE dimmers set to ~1%… practically invisible. I believe what’s happening is the guest is not familiar with the smart dimmers and instead of hitting it only once to turn off, they hold it down until it’s dark. This leaves it set at a very low level so the next time it’s turned on, it’s too low to see and seems to do nothing.

Any ideas how to prevent this?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

The hardware can’t prevent it; so there’s two options:

  • Only provide a “software” switch (or remote like a Minimote, some Hue options I think, or ActionTiles if practical).
  • or … Have a SmartApp (like CoRE) watch the Switch for a low dimmer value being triggered and have it instantly override with a more practical value.

(Micheal ) #3

I found this same issue as well recently with the guest room. CoRE can be used that when it senses you turn on a light (and it is set to a low value) to override the value and instantly set it to 100.


#4

I like to be able to have it low if I want it low, so I just have a routine called “reset lights” which resets everything to my default values. :sunglasses:


(Alan) #5

What is the variable to test if a bulb is on/off? $current… perhaps? Or must you capture the state first?


(Alan) #6

Figured it out. How to get bulb level:

Using Bulb
-Save attribute ‘level’ to variable @lgtLevel
-do something with that value

How do you get the bulb level?


(Robin) #7

As turning a light on to 1% is often invisible to the user (and therefore pointless), I have a simple piston always running in the background (for each effected light):

IF
switch changes to on
AND
dimmer level is less than or equal to 5%
THEN
set level to 100%

I can still dim down to whatever I want if required, as the trigger is the light turning on, not a change of dimmer level.


(codersaur) #8

Does the device not have any firmware parameters that you can set to prevent this?

I have no experience with GE Dimmers, but with the Fibaro Dimmer 2’s there are several parameters you can set in the firmware to prevent this. E.g. Minimum Dimmer Level and also Forced Switch-on Level so even if the level as set by a previous user to 1%, it will still go to a level that you’ve specified when switched on again.

If not, you would have to implement something in a SmartApp like the CoRE piston @RobinWinbourne suggested above.


(Robin) #9

I initially tried the same with all my Fibaros, but I wanted to keep the option of low level dimming and I also didn’t like loosing the previous dimmer level every time I turn them on (unless below 5%).

The CoRE piston is a nice solution.

I’m not sure if GE dimmers have the same level of configuration options either…


#10

Thanks RobinWinbourne, using a Core Piston seems to work for me. I’m doing less than or equal to 10% though, since this particular combination has a super steep ramp.

I’ll be setting these up for quite a few rooms.


#11

zcapr17 - Wish that were possible, but if it was, I wonder if there’s a way to simply prevent dimming between 0%-5%, since it’s pointless anyway.


(codersaur) #12

on the Fibaro Dimmer 2, that’s what the very first parameter does.

You simply ‘cut out’ the range where there’s no visible difference so it helps give the dimming action a more linear feel.

Any decent dimmer should be able to do something like this. I would double-check with GE that it’s not possible.


#13

I decided to skip CoRE for this one, since I don’t need these rooms to remember their last brightness level. I found this app, which just resets them to 100% every time they’re turned on: Dimmer on bright


(Glen King) #14

I’m glad I’m using smart bulbs rather than wall dimmers… and that we are using Alexa for basic lighting functionality. Wife and I both know we can tell any light, be it Hue or Cree, to “turn on X percent” via Alexa and it does it. And guests simply flip the switch - and when that does not work (because with Alexa we always have the switches ‘on’) they flip it again, which turns on whatever bulb is attached at 100%.

Alexa has vastly ramped up the WAF. :slight_smile:


(Alan) #15

It just so happens I now have a similar situation. I have Cree Connected bulb in a small fixture with the switch always on. If someone pulls out the plug and plugs it back in, the default for the Cree is to go 100%. However, ST does not register the bulb as on until about a 1 minute 30 seconds have past.

Is there a way in coRE to push this check on the bulb sooner? I’m not familiar with what ‘ping’ and ‘refresh’ do or if those are what I might use. Suggestions?

Thanks.


(Robin) #16

You could setup a piston to refresh constantly but it will slow down your hub considerably and will also put unfair load on the ST servers effecting everyone else.

Maybe swap the plug socket for a fused spur (cord outlet) and hard wire instead, then nobody can un-plug it!


(Alan) #17

Thanks, but outlet change not possible. Understand about the refreshing. Tried it once and almost crashed things.


(Don) #18

I don’t have Cree but osram bulbs. There’s an app called canary or something like that. It monitor’s smart bulbs to turn them back off after power cycle.

Would something like that work?


(Alan) #19

Maybe, have to see. Where should I look for this app? Thanks.


(Don) #20