GroveStreams as an alternative to Xively?

logging

(Jim) #1

I was going to try Xively based on one of the threads on the Aeon power monitor device. I ran into a snag, they’re no longer allowing free developer accounts.

I was digging around and found GroveStreams.com - has anyone else tried it? The API is straightforward, and their UI/data manipulation tools are pretty slick, and they have a free dev account. I asked, and they’re interested in getting more hobbyist developers experimenting with their systems.

There are per-minute call quotas and so forth, but been working fine for my purposes.

Has anyone else tried them?


(Geko) #2

Wow! I guess all good things come to an end eventually. Another example how acquisition by a large company inevitably turns good stuff to sh*t.

There’re few alternatives still:


http://exosite.com
https://www.carriots.com
https://www.grovestreams.com
https://thingspeak.com
http://openenergymonitor.org


(Jody) #3

Thingspeak has an opensource server. I had mine up and running in less than a half hour. It appears you can still get a free developer account over xively as well.


(Brian) #4

Do you guys have some general feedback on each of these? These are my impressions so far, and I’ll take anything I can get. They take an investment in time, which I am doing, but it’s slow going for me. Any pointers would be great.

  1. Bidgely: Nice app, easy to use, has appliance detection algorithms, doesn’t support electric cars/geothermal (not a big deal), nice energy notifications, difficult to fix problems like accounts, etc,.
  2. Thingspeak: Haven’t dived in, on the face of it, looks nice but can’t see anything yet.
  3. Grovestreams: Looks dated, but quality so far. Seems a lot of people use it.
  4. Initialstates. Nice ST integration, nice graphs, I broke some and haven’t checked out what happened yet.
  5. Plotwatt. Nice SmartApp, but takes a little bit to get off the ground, and now I’m stuck back on “unauthorized” which is probably a throttling issue, but I can’t self fix, I’m waiting for their support to respond.

Phew… will try to edit this post as I find out more.


#5

@bridaus - Did you ever get your ‘unauthorized’ problem with Plotwatt fixed. I’m running into the same thing.


(Brian) #6

Yes, you need a meterID, you probably saw by now this was answered in the other thread about Plotwatt.


(Aftab Sarwar) #7

Have you guys tried ThingScada?
http://thingscada.com


(SP) #8

Anyone tried https://www.hundredgraphs.com ? Looks simple enough to push data