Groovy apps future support?

groovy

(Bruno Sutic) #1

Hi,

my company is looking to integrate with SmartThings platform, specifically using the Z-wave devices.
Now the problem is: the old platform that has full Z-wave support seems to be deprecated link http://developer.smartthings.com
And the new platform misses Z-wave support New dev portal: Z-wave support coming soon.

Does anyone know for how long is Smartthings going to support the old developer’s platform? Are existing groovy apps going to be migrated to the new platform or are they going to be killed some time in the future?

Thanks for any info on this!


(Steve Jackson) #2

Your best bet would probably be to contact Samsung/Smartthings directly.


(Robin) #3

They aren’t telling us when things will stop working.

But from what I understand, existing groovy handlers will work on the other side.

You’ll also be able to use more complex languages though… groovy is clunky and outdated so it’s not all bad.


(Robin) #4

(Keith Croshaw) #5

I’m happy to see questions like this. I think the entire community is concerned.


(Arn B) #6

If you are a developer you may want to fork a copy of the ST documentation while you can.


(Dave Gutheinz) #7

However, being 69, clunky and outdated, I really like the groovy platform!!!


(Arn B) #8

True enough. Hopefully they will support COBOL and Fortran. :exploding_head:

I thought Groovy was supposed to be an “easier and less restrictive” version of Java? Once I understood what I was doing with Groovy it was similar to my coding in PHP, except the ST groovy version of Regex is difficult to use.