Govee DreamColor LED Strip Lights with WiFi and Smartthings?

I could not get it to turn the lights on and off… any suggestions. Govee Model h6159

Did you open the index.html page, insert your Govee API key, to retrieve your Govee device names, models and IDs?

Yes… it shows up on the SmartThing App, but I can’t control it… Curious if you need me to send you any more details.

Suggest you log an issue on the GitHub page, so the author can assist you.

Alternatively, you can download the application “Postman” from https://www.postman.com/downloads/
Then create a new “GET” request, so that you can see what information you get back from the Govee-API.

The image shows example to retrieve the device state. In my case model H6104 does not support device state.

Was able to get this setup and working tonight…thanks!!!

Is there a way to get Smartthings to pull in the saved colors that I already have setup in the Govee app or the current color?

Working like a charm on my H6199

Thanks!

Will this one https://www.amazon.co.uk/Govee-Wireless-Controlled-Lighting-Assistant/dp/B07QCMCVD7/ref=sr_1_1_sspa?crid=32HYAFGCOENQJ&dchild=1&keywords=govee+led+strip+lights&qid=1614601827&s=lighting&sprefix=govee+led%2Clighting%2C244&sr=1-1-spons&psc=1&spLa=ZW5jcnlwdGVkUXVhbGlmaWVyPUE2QUlYSkFKMTlaTkEmZW5jcnlwdGVkSWQ9QTAzOTEwOTMxVU9VT1NCMUk4SUdaJmVuY3J5cHRlZEFkSWQ9QTA0NTM2MDUyMFlZVlI3TlJYOU5QJndpZGdldE5hbWU9c3BfYXRmJmFjdGlvbj1jbGlja1JlZGlyZWN0JmRvTm90TG9nQ2xpY2s9dHJ1ZQ==) work if we use the github code?

I am stupid. I don’t get what KED Device ID is. I understand it is in the configuration tab. But I only see the modelnumber

Thanks for all the information here and all the work that has gone into integrating the Govee LED strip lights with SmartThings. I have the H6110 lights which allow different colors and a ‘sound to light’ mode. Does the uncdubdiver driver on GitHub support these modes? In particular the modes I need are on/off, bright/dim and color selection.

Thanks!

i was getting some errors from the smartthings plugin when I setup Homebridge and finally pinpointed them to my Govee device from this integration.

[3/14/2021, 2:52:06 PM] [homebridge-smartthings] This plugin generated a warning from the characteristic 'Hue': characteristic was supplied illegal value: number 0 exceeded minimum of 1. See https://git.io/JtMGR for more info.
[3/14/2021, 2:52:06 PM] [homebridge-smartthings] Error: 
    at Hue.Characteristic.characteristicWarning (/usr/lib/node_modules/homebridge/node_modules/hap-nodejs/src/lib/Characteristic.ts:2164:105)
    at Hue.Characteristic.validateUserInput (/usr/lib/node_modules/homebridge/node_modules/hap-nodejs/src/lib/Characteristic.ts:2114:14)

removing that device from homebridge fixed it. not sure if there’s a way around it, but its not a big deal since it still works fine in ST.

Thanks for this thread! Worked for me and H6117.

Any way to get the “Music” or “Diy” modes integrated into SmartThings?

Sorry for the nubie question but I’m kinda stuck at this step. I got my API key but unsure how to get to index.html link to input the key.

You have to download index.html from Govee LED Lights - Device Configuration and open it with your browser, i.e. Google Chrome
Like is written on the github page:

This index.html file will provide you step-by-step procedures on add the device and device type handlers into your SmartThings account

I had same issue where once I download index.html file it would open same github page.
Open that index.html in a editor (Notepad++), delete everything and paste “raw” code from github into it and try to open again in Chrome. Good luck!

Any luck with your lights? I had those working but when I added another set H6141 they stopped. I tried removing both, getting new API and setting up new in ST still nothing. H6141 still works. Very odd

Same here. Can’t turn off H6199.

I have a H6199 and I don’t have any problems.
Try re-add it

Removed everything and re-added everything. Still cannot control it. On SmartThings web interface I can see logs of me trying to turning it off/on, but nothing is actually happening. Any other suggestions?

Just want to say thank you to @jc73uk, the author of the DH and all of those that chimed in here.
It is working great. Just wish I could select some scenes from the Govee app in the smartthings.
Thank you again!

2 Likes

Hey guys,

There definitely seems to be an issue with model H6141. I followed the steps twice to make sure I didn’t miss anything. The device shows up in the app in a turned ON state, however I cannot control it. Am I missing something here? TIA