SmartThings Community

Google Home


(Neal (www.zebrablinds.com / www.zebrablinds.ca)) #1433

New update!

You can play music from your own library now. Article below:


(Brent ) #1434

Yes I consistently have issue with devices not responding to commands from google home. That being said I’m not sure if its google or smartthings that’s the issue. I have a mix of Hue, LiFX and Lutron Caseta, and WeMO switches. It does seem to be specific to any of them sometime one or two just don’t respond to on/off or color change. It seemed like its gotten worse, I believe google did an update to the Home app and now my chromecast audio and video integrations are broken and they have no answer.


(jkp) #1435

#1436

I seen that too. Now that is cool. No Membership fee (PRIME) and free shipping if you meet the minimum requirement. I am so there. Now Add the GH Calling which I tested yesterday from my Google Home device and you have a Winnet!



#1437

Only kind of tangentially related to the thread, but thought might be useful to someone. I have been pulling my hair out since GH calling would not work. I would try to make a call, it would respond that it was and spin the lights, then say there was a glitch or something went wrong and try again. Last night I decided to stop waiting for a fix and see if I could figure it out. After trying all sorts of things including looking a router logs, changing router filtering settings, resetting the device, I decided to connect to my 2G wifi instead of my 5G. Voila! It works!


#1438

False alarm. Back to not working. :frowning:


#1439

Finally think I figured it out for real. It was that my router had parental controls using OpenDNS turned on. Even if I set the Home to have no filtering, or turned the default level to no filtering, it still caused a problem. I was able to turn on/off and it didn’t/did work twice so I am pretty sure that’s it. Now I have to choose between the filtering and the calling :thinking:


(Andrew Caudle) #1440

Can you set up a separate wifi network (perhaps using the guest wifi) for the google home without filtering?


#1441

Thanks for the suggestion, but I already checked that out. Looks like my DNS settings are global for the router. I can’t see a way to configure it one way for the main network and another for the guest network. The xfinity access point of one of my neighbors does show up but its just weak enough the home won’t latch onto it.


#1442

So I’ve added a few ST momentary push buttons to my set up. What is the correct voice command for Google Home for these? I’ve tried “turn on”, “start”, “toggle”, and “push” and now I’m out of ideas.


(Micheal ) #1443

“On” should work…Hey Google, turn On {switch}…be sure to check the log of the device…momentary switches do revert back quickly so you may not be seeing the change.


#1444

That’s what I thought. But GH just keeps telling me she isn’t sure how to help.


(Micheal ) #1445

hmmm…that is odd…but regular switches work ok?


#1446

I thought so too. Yes, regular on/off switches work fine with my GH.


(Micheal ) #1447

Ok…and you are ‘discovering’ the switch within the Google app? I have never had an issue with virtual switches…will need to try this tonight…


#1448

Yeah, the GH app picked them all up automatically. They are being used to control my Roku TV: [RELEASE] Roku Virtual Buttons

I was thinking of going into the IDE and changing it to an on/off switch, but I don’t know if this will work with device handler that these guys set up for Roku.


(Micheal ) #1449

Try setting up a virtual on/off instead of a momentary switch to see if that helps.


#1450

Update: Yes changing it to a “On/Off Button Tile” did the trick. The GH worked no problem.

Now I’ll just use webCoRe to set the automation to what happens when the switch is turned on/off.

Thanks for the input. If you DO happen to play around with and get the momentary switch to work, I’d be interested in the solution.


(Micheal ) #1451

I will play around with it.


(Cesar Vasquez) #1452

Any update on this? Google Home Mini can be a perfect match for notifications with SmartThings