Google Home with multiple Smartthings Locatins


#1

I understand that Google Home will currently only work with one Smartthings location. I have one Smartthings hub in my house and one at my girlfriend’s house. I was able to get them both working with Smartthings and then when we got Google Home devices, I was able to get both environments to work with voice commands. No problems at initial setup time.

The issue comes up whenever I reset my phone and have to reconfigure my Google Home software. I can confirm that Smartthings works by just logging in and all is good. When I go into Google Home, I have to add Smartthings back to it, I can log in with my Smartthings API account and because I have two locations, they both show up and I am asked to pick one. If I pick each location, then it shows me the list of devices at the appropriate location. Good so far.

My girlfriend’s location is at the top of my location list (even if I rename mine to sort alphabetically higher) and when I try to add my house, it shows me the correct list of devices but when it goes to sync up, it consistently pulls her house’s devices into Google Home instead of mine. I have tried blowing away my location and rebuilding it all with a location name that sorts higher than hers in the alphabet, but hers still is at the top of the list in the API web site.

The last time I had this issue, my only option was to blow away her location and then Google Home only saw mine and added all of my devices. Then I had to add her location back and it all worked. Not sure why it didn’t cause her Google Home to pull my devices, but it worked.

I’m wondering if there is a more elegant and less destructive way to get the correct location information pulled into Google Home when you have multiple locations.

Is there a way to change the location sort order in the API site?

I suppose I can try power down her hub in the hopes that it not being active will help but that requires driving back and forth.

Any suggestions or insights are appreciated.


(Markhuynh) #2

I have the same issue as you. It will only pull in things from the first location. Someone from SmartThings need to look into why their API is not working as intended.


(Andy Nguyen) #3

Guessing no luck with this issue? It’s been a year and I’m still having the same problem :frowning: