SmartThings Community

Google Home Assistance - problems with ST - KNOWN issue to Google


(Larry Tuff) #166

Using only Android devices here as well and always get the same ‘Couldn’t update the setting’ notification (from day one). Grabbed my wife’s iPad Mini2 half an hour ago and installed the GH App, logged in under my gmail and tried to link to ST there. Got the ‘Something went wrong’ notification. Left the screen blank for 15 minutes and tried again (same notification). So seems neither iOS nor Android is allowing me to link GH to ST. LT


(Travis Mielonen) #167

Just tried doing this on my iPad air, got the “something went wrong” after about 15 seconds or so staying on the blank screen. Every time.

But now I have a question, how do we check the authorized connections in our SmartThings account? I’m curious if there’s some kind of stuck authorization from before? I don’t see any kind of SmartThings authorization in my Google Account, but I don’t know how to check in SmartThings to find external authorizations.


(Wesley Wong) #168

I can confirmed this is not the root cause either you wait the blank screen or just back to main menu from the button. Both are appear the same error message in iOS.


(Wesley Wong) #169

I believe this is not the rare case since a lot of members face the same issue. Can I confirm your callback URL similar like what I posted above?


(Travis Mielonen) #170

Hi @wesleywong, I have the same URL (and it’s not authorizing) - I’m curious if anyone who has a working authorization is getting a different callback URL? OR If this is the wrong callback for us on the EU shard?

https://graph.api.smartthings.com/oauth/confirm_access?response_type=code&scope=app&redirect_uri=https%3A%2F%2Foauth-redirect.googleusercontent.com%2Fr%2Fsmartthings-9c579&state={stateID}client_id={clientID}


#171

Alright, we have figured out the root cause.

It seems to be caused by using custom Thermostat DTH:es that have both capability switch and thermostat like examples below. We are working on testing a fix now.

If you are NOT using such a DTH, can you let me know either in this thread or via PM since we might be dealing with multiple issues.

EricG66 : SensiboPod
gouldner : ZXT-120 IR Sender Improved
tommysqueak : POPPTRV
gouldner : ZXT-120 IR Sender Improved
KeithR26 : Intermatic PE653 Pool Control System

While waiting for the official fix, if you want to get it working you could just comment out this line (// capability “Switch”) from the DTH, save, and publish. Not sure if it will impact the functionality of the device though, that is up to the implementation of each DTH.

Thanks you all for providing info!

Lars


(Alexander Ng) #172

Not using a custom thermostat dth. I am using the native app and dth for the Honeywell Lyric Round and Honeywell Lyric (Connect). I’m also not getting the 500 error msg like others. When I relink, it says I have linked ST successfully and 0 devices found even though I it appears on the list to select or deselect. Never see the new Google smartapp when relinking, I only see the old The Google Assistant on my ST smartapp screen. I already put in a call to ST support as well as to Google support with my findings and tests


(Larry Tuff) #173

Ooh, good work. I do have EricG66: SensiboPod and commenting out the [capability “Switch”] line has now allowed me to successfully link GH to ST! (ST can no longer turn on my SensiboPod though so I hope that can be fixed). Great Work!!


(Travis Mielonen) #174

Nice!

I had a few different thermo DTHs which had “switch” this breaks a few things… but I was able to successfully re-link to Google Home! Strangely though it at first told me it didn’t work… then after I refreshed the page it showed the account linked with 78 devices…

I’ll now try to allow only certain devices, not all 78! To get what I want loaded into GH, then re-add the switch capability… and hope everything works ok?


(Travis Mielonen) #175

I re-enabled the “switch” capability in each DTH after adding only the devices I wanted back into GH as I wanted using the Google Smart App in the ST app… All seems to be OK and working as expected.

Thanks!


#176

Is the thermostat still included in the list of Google home devices? If so, it might break again later because there are devices syncs happening in the background (when devices are added, deleted or renamed).


(Travis Mielonen) #177

Yes, they are. I’ve renamed a few devices already and everything seems to be working right along - except when a sync happens the GH “Nickname” gets wiped out on all devices, regardless if they were renamed in ST or not.


(Jason) #178

@AlexS Hello, I uninstalled everything, but now when I got back to the google app to relink the account the page is blank. Any suggestions?


(Travis Mielonen) #179

@Lars & @AlexS,

So, here’s the latest. If I include the thermostats as “thermostats” within the Google SmartApp in the ST app, then things stop syncing. If they are only included as “switches”, then everything buzzes along fine, and I can still ask Google “What’s the temperature in XYZ?” and it reports the thermostats status and temperature… so FWIW that’s all for now.


(jkp) #180

This might explain your issue…
https://status.smartthings.com/


(Jason) #181

Thanks for the info


#182

Commenting out the switch line did the trick for me, I am able to add all my devices to Google Home.

Thanks @Lars for figuring this out, it was driving me insane.


#183

Commenting out the switch capability line in the Sensibo pod device handler did it for me as well. Im back online now - many thanks for sticking with it team, looking forward to the solution!

As a side note, I was never able to control the Sensibo device via the GH/ST integration anyway. I have a post about it somewhere. Only way to get it to work is via the direct Sensibo - Google Home integration - Hey Google, ask Smart AC to turn on the downstairs AC"…bit of a mouthful.


(Jason) #184

Ok, my issue is not related to the outage. I go to google assistant and to to settings and then home control. When opening that page it used to use SmartThings and I could login, now that page is blank, I cannot even start the login process. Any ideas?


(jkp) #185

I’d recommend looking at @AlexS post

Otherwise contact @Lars or @AlexS

:slight_smile: