Google Assistant errors with thermostats

I’m getting that error when I ask Google Assistant to change the temp from my “Thermostat”.

I’m using a ZXT-120 infrared thermostat to control split unit ACs.
From SmartThings everything seems to work fine but when using Google Assistant I’m getting two errors that I’m worried about.

  1. When Google Assistant replies that a command succeeds it can’t say the device name… instead the name is substituted with “unknown error”… For example it’ll say “OK, encountered an unknown error for the AC”… funny thing is that the command actually succeeds.

  2. I can ask Google Assistant to change temp with no problem. I can ask Google Assistant to turn Off the AC with no problem. But If I turn off the AC with Google Assistant I can’t turn it on again. If I try to tell Google Assistant to turn the AC on or change Temp I get “The AC is off right now, so I can’t make any adjustments”. Only way to turn it on is trough SmartThings by setting any temp.

I understand this can be a Google Assistant problem and not related to Smartthings but would like to know if there’s any way to make sure it is. Like a log I could look at or some way to confirm where is this error happening.


Not sure if it’s related to the following issue or not:

Thanks for your reply, unfortunately it’s not realted. My devices do show up and do have the thermostat capability. In fact I can control them from Google Assistant witouth problem.

But Google Assistants will call them Unknown Error… and Google Assistant can’t do anything with them once they are turned Off.

1 Like

I run into this same issue very occasionally with my Google Home and my Honeywell t-stat… It seems that Google just dumps the t-stat account’s credentials every now & then for some reason.

Fortunately it doesn’t happen to me very often (once every 3-4 months or so), but it did happen to me recently, so may Google had a widespread glitch.

Anyway, the fix that works for me is this: Disconnect the Honeywell account in your Google Assistant app (or Google Home app in my case), and then just add it right back in, and then it should all work as advertised once again… Basically just the ol’ “off/on” trick.

Good luck!

Tried it… No dice.

Ok… watching the Live log (just found it… sorry new user) I can see that when I say “Turn AC on” Google assistant is sending the following command: “Executed Thermostat.setThermostatMode(heat, ) on device d35be5f6-7020-4a80-8ea7-8734031992f0”

I believe thats where the problem lies as my thermostat does not have a heat mode. Now, anyone knows why the On command is being defaulted to HEAT?? and does anyone knows a way of defaulting that Assistant command to COOL??