GoControl/LinearLinc Bulbst

OK, another dumb question.

I have four GoControl bulbs that I bought on Amazon because it says they are SmartThings compatible. I’m sure they are, but I have no idea how to add them. I have an Android phone and it doesn’t see them as new devices. If I select to add them manually, and click bulbs, it doesn’t give me an option for GoControl or LInearLinc. I tried selecting the ones that are there in turn but nothing seems to make it work. Any ideas?

Those are standard zwave devices. You should be able to add them as a “zwave thing” and then choose a generic Z wave dimmer in the IDE And that will control the dimming. Are they white only bulbs or are they RGBW color bulbs?

Also, are you using the classic app or the connect app?

They are white only bulbs. The one I tried has suddenly appeared this evening. It showed up as Dimmer and connected, then went offline and won’t come back on :frowning: I’m not sure which app I’m using. I didn’t realise there was more than one (this is making me sound a bit of a dumbass now). How do I tell?

The logos on the two apps are different:

See the FAQ ( this is a clickable link)

It sounds like you might have a range issue. Or a blocked signal issue. How far are they from the nearest zwave repeater?

Also, with bulbs you always have to consider the material of the fixture. If it’s leaded glass, that can be a real problem.

Try running a Z wave repair and see what error messages you get:

OK. I defo have the Connect app. I’m downloading the classic and I’ll give the repair a whirl. Thank you for all your help. I would be struggling in the dark with you. :slight_smile:

1 Like

Getting the bulbs working will fix that. LOL! :stuck_out_tongue_winking_eye::bulb::bulb::bulb::bulb:


Still struggling (not so much in the dark though, thanks JD :)). Running the repair gives me errors saying the three devices I can’t reach “Failed to update mesh info” and then “Failed to update route”.

I added the 3 other bulbs using the classic app (that’s much easier than the connect app) one of them is connected happily. Another was discovered, I named it, and then it disconnected. It won’t come back on no matter what I do. This is one of the ones reporting the above errors.

Is removing them and trying again the only option?

Where are they physically located in the house? And what is the distance both from each other and from the hub? Also list the number of wells in between.

And speaking of wealth… Local architect or can matter a lot. If you live in an adobe or concrete house, it can be difficult to get signal through walls. Also if your house has plaster walks over chicken wire lathing, which was a common construction style in the early 20th century. Water pipes in the walls for radiator systems, mirrors on the walls, foil backed wallpaper – – any of these can Block signal.

So you could try bringing all the bulbs into the same room with the hub temporarily, just putting them into table lamps, and see if they can be found then. At least that will tell you if the issue is placement rather than the device itself.

The hub is upstairs in our bedroom. This is the front of the house as this is where the internet router gets the best signal (It’s an AT&T wifi hub, we don’t have wired here). The SmartThings hub and the Hue Hub both sit here. The nearest bulbs are in our bathroom through the walk-in wardrobe. There are two lights in there, a wall one (with the GoConnect bulb) and a ceiling one (with a Hue bulb connected to a Hue sensor). The hue sensor detects all the time, but the bulb only reacts half the time. The GoConnect bulb was seen initially but went off line straight after I named it.

Downstairs we have 3 Hue strips in the kitchen. These connect and seem to work reasonably well (sometimes they won’t react individually but will when the kitchen group is switched. We have 6 ceiling bulbs running through downstairs, four are Hue and 2 are the other GoConnects. I’ve spaced the GoConnects so that one is furthest away, then a Hue, then the other GoConnect, followed by the 2 Hues. This works and all of these are connecting. The others that are showing as disconnected are the outside strip (Sylvania), although this does come on with a schedule (but didn’t go off last night), and the outside GoConnect by the back door. The Sylvania strip is by the front porch and so is arguably the furthest from the hub. This is why I had the repeater GoConnects. The nearest one of these is about 3m away from the Sylvania strip. The back door GoConnect is about 3m from the nearest hue on the same floor, but about 5m below the hub (plus about 5m on the same floor). The last one is a Sylvania indoor strip. This will eventually go behind a sculpture on the wall about 8m from where it is now. It’s currently the furthest away inside the house plugged into a wall outlet beneath the last GoConnect. I thought the GoCOnnects would enable them all to see the hub, but it seems they only repeat to each other.

The house is constructed, as most in Mexico, from breeze blocks, so the walls are all about 4" thick with plaster etc on the tops. We have no stud walls at all, but lots of glass, and all the pipes are internal to the walls.

I know our dodgy internet doesn’t help but internally they should be fine with the repeaters I would have thought. I tried bringing the Sylvania strip to the kitchen and it sees it fine there so I think it’s definitely a range issue, but I thought the whole point of the GoCOnnects is that range isn’t an issue as long as they can see another and the hub through the chain.

Zigbee repeats only for zigbee and zwave repeats only for zwave. Aren’t your Sylvania devices zigbee? The gocontrol bulbs are Z wave, so they can’t repeat for the Sylvania zigbee devices.

Also… Devices connected to the hue bridge form their own mini network and only repeat for each other. Not for any of your other zigbee devices.


Finally, no one cares about the following but me, but still… :sunglasses:

Your walls are going to be very difficult to get signal through. That’s why your outdoor lights are failing. You will probably need to have a repeater of the same protocol as the outdoor bulb near a clear glass window on the same side of the house.

If you want a bulb that will repeat the zigbee signal to the Sylvania device, assuming the Sylvania device is joined directly to the hub and not to your hue bridge, try an IKEA Tradfri bulb joined directly to the smartthings hub, not to the hue bridge.

I would love to have some IKEA bulbs. They are a fraction of the price of all the others. Unfortunately IKEA haven’t made it to Mexico yet (we’re a good 5 years behind in stuff like that)


Tim Foster

Global Pacific Corporation

I realize this is an old topic, but this exact same situation happened to me as @Tim_Foster. I purchased a GoControl dimmable BR30 bulb from Amazon and try as I might I could never get it to show up in the SmartThings Connect app when I scanned for devices. I was about to return the bulb as defective but then I found this thread, so downloaded the SmartThings Classic app and BOOM - the light showed up almost instantly in the Classic app. I saved it in the Classic app, and when I switched to the Connect app, the light was listed correctly and it simply asked me to confirm the room. I could then control it from the Connect app.

Wanted to document this for completeness of the solution - thanks guys!