Go Control zwave thermostat- network error changing settings

I have had a Go Control thermostat for several years and it has worked up until a few days ago. The status info is coming inbound to ST and other interfaces fine, but the ST device control for raising and lowering temps will give ‘A network or server error occured. Try again later’ error. I did need to replace the batteries recently which also shows status of full battery percentage okay. Is there some sort of cloud reliance on the control side? I can only change fan or temp settings at the stat on wall. thanks in advance.

What Edge Driver are you using?

I am in using the ST Beta Z-Wave Thermostat driver and I am not have any problems.

1 Like

thank you.
it is “z-wave thermostat” (smartthings is dev) and version is recent (2023-09-05Txxx.850629765). This is probably when problem started since it was working before. Would it be triggered by an update push or could going offline with battery replacement cause it to re-up the driver? I am not sure what driver it was on before that. I wish I could spreadsheet my device information like the old IDE.

Lastly, when I look up under select a different driver, only “zwave switch” shows up as available on my hub (even though I have several edge driver ‘joins’ for Zooz, etc. I don’t understand the switch driver process anymore.

Hear is the beta version I am using. Add it to your hub and try it.

thanks. I will try to replace and report back.

There is a community-created project that gives you a nicely formatted web interface to your account, if that’s of any help:

SmartThings API Browser+ ... Now Available to All

If you prefer to use the official feature, you have to use the “advanced“ page in the official web interface:


Also, there’s a Community FAQ about edge Drivers, that might clear up some of the confusion:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

Or, if you just want a short explanation, there’s a Community FAQ just on the process of changing from one edge driver to another:

FAQ: How to change to a different edge driver

It autoconverted the drivers. It looks like the same beta version. But I don’t have ablity to update the temps from ST (get same error about network). Now I also get a ‘this device hasn’t updated all its status information yet’ error. This is same error I get on a Zen32 ZOOZ scene controller switch (and have for a while) which has sporadic settings greyed out on it while others work.

I will check it out, Thank you! I guess I am behind the times in the updates :slight_smile:

1 Like

Hi @mark_price

Your hub may have been updated to firmware 49.9, not booting correctly, and you need to reboot the hub.

1 Like

thanks, I did get the 49.9 update. I can’t find out how to reboot anymore now that IDE is gone and android app hub device settings have changed. (I also browsed the new web interface with nothing found. So, I unplugged my V2 and still have both errors [and not updating commands but device status is coming through.]

Are you removed the battery too?

You can use my.smartthings.com advanced user.
Menu Hub and click in your Hub

1 Like

Thanks. I found that and rebooted. Now many devices show offline after 30mins. I am waiting to see if they will come back up. I don’t know how long it takes to reconnect certain devices after reboot.

In recent months battery powered zigbee devices are often shown offline after a reboot, and can take several hours to be listed as online again.

They are not really offline. For example with a door contact, if you open the door, it registers in the app as open, and the devices is then listed as online.

1 Like

Good to know. This is a zwave of course- that did just come back online (albiet slower than other zigbee devices, like sengled bulbs) and t-stat still has the errors I mentioned after the reboot.

update- after nearly a day, I still have no control over my GoControl thermostat and I think the time based automations aren’t triggering either. Is there something about the latest update or drivers that cause either the network error or ‘the device hasn’t updated all the xxx’ error? It appeared to be working before ~4 days ago both in groovy era and edge. It is wierd that status updates to ST device, but can’t control settings. Below log shows only the changes made on wall t-stat, but no log for ST device in app (android or new web front end), just the common errors.

Hi @mark_price

It may have to do with platform problems in some areas, which other users are reporting.

If you want to rule out that it is the fault of the edge driver, you can install my Z-Wave Thermostat Mc driver on your hub from my channel and make a driver change

thanks, Mariano. I got drivers switched and can see it took, but still have both errors. I will wait it out and track platform level. Thanks again for all the bringing me up to date [been a little behind on the conversions in recent year or so]. Things just got a little more wonky and/or slow since moving off groovy, even though in theory, I guess more is localized.