Gledopto Zigbee RGB controller

thanks @benerkens
I am new in Smartthings. when i copy the DTH i get this fout:

Org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: script_dth_metadata_8a2f008b_5ff8_424e_b440_134dd1f80cb5: 15: unexpected token: RGBW @ line 15, column 27. definition (name: “ZigBee RGBW Bulb 2000-6500”, namespace: “smartthings”, author: “SmartThings”, runLocally: true, minHubCoreVersion: ‘000.019.00012’, executeCommandsLocally: true, genericHandler: “Zigbee”) { ^ 1 error

Hi,

Can you explain this in a little more detail ?
What is a DTH, how do I change it and upload to ST IDE ?

I have ordered two Gledopto ZigBee controllers and will try the DTH. In the meantime just wanted to let you know what I did with my Wifi LED controller to address the same issues.
Using MagicLight Wifi, the RGBWW Light strip was configured. To get only the RGB to light up and not the WarmWhite, I created a “scene” in MagicLight Wifi that set the WarmWhite to “zero” and called it Lincoln. Then when turning on the LED, the WarmWhite would sometimes get turned on. Running the MagicLight Wifi “Lincoln Scene” the Warm White was turned off and the RGB would be 100% red or blue, etc, without any white.

As another option, if the controller was configured as a RGB/CCT, instead of a RGB/WW controller, giving the command to turn on CoolWhite would turn off all white LED’s. This happens because the strip is a RGB/WW and doesn’t have any Cool White LED capability.

To enable the strip to be a WarmWhite and not include any RGB light, I created another scene called Garfield which turned off RGB by setting any RGB color to “zero”. Then the Warm White would be 100% white.

These options that I’m doing with MagicLight appear to be a similar approach to using the Smartthings DTH.
The latest DTH approach definitely looks more efficient and adds granular color controls, so I ordered the ZigBee controller. I’ll let you know how it works.

But, just to let you know I did get the RGB Wifi controller working with Smartthings. I wanted to control the lights via Alexa, so I installed the MagicLight Skill and by voicing the commands the light would change colors. Then to get it integrated with Smartthings and ActionTiles, a virtual switch was created with the same name as the Magic Light skill. Then created an Alexa “routine” which responded to the Smartthings virtual switch and turned the RGB light to either WarmWhite or a RGB color. Now ST/ActionTiles can turn on and off the LED lights like any other device. Giving verbal commands to Alexa will change the colors and or levels.

Looking forward to seeing what the DTH can do with the Gledopto ZigBee controller for my RGB/WW LED strips.

the problem is that the quotes are special characters and not the vertical quote characters, so the compiler thinks that they are characters/letters and not quotes. They should be “ZigBee RGBW Bulb 2000-6500”, not as shown with the leaning quote characters like this, “ZigBee RGBW Bulb 2000-6500”,. I had to import the whole script into Notepad and find and replace all of the quotes with the vertical quote characters. Then it works.

Now I know where the problem is. It’s the blog. It’s converting all of the quotes to special characters, when it’s posted. Not when it’s being typed. Anyway, paste the script into notepad or Word, do a find and replace with a quote character that you type into the replace box, then it will work.

Still getting the following error after replacing all the quotes. Can you share your code from Git?

Org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: script_dth_metadata_11db0f2f_b803_4e4e_b93b_e3bd10d0d038: 131: unexpected token: } @ line 131, column 1. } ^ 1 error

Here’s line 124 to line 141. Try copying the appropriate lines and pasting them into the code. Be sure to clean up the quotes.

if (zigbeeMap?.clusterInt == COLOR_CONTROL_CLUSTER) {
if(zigbeeMap.attrInt == ATTRIBUTE_HUE){ //Hue Attribute
state.hueValue = Math.round(zigbee.convertHexToInt(zigbeeMap.value) / 0xfe * 100)
runIn(5, updateColor, [overwrite: true])
}
else if(zigbeeMap.attrInt == ATTRIBUTE_SATURATION){ //Saturation Attribute
state.saturationValue = Math.round(zigbee.convertHexToInt(zigbeeMap.value) / 0xfe * 100)
runIn(5, updateColor, [overwrite: true])
}
}
else if (cluster && cluster.clusterId == 0x0006 && cluster.command == 0x07) {
if (cluster.data[0] == 0x00){
log.debug "ON/OFF REPORTING CONFIG RESPONSE: " + cluster
sendEvent(name: “checkInterval”, value: 60 * 12, displayed: false, data: [protocol: “zigbee”, hubHardwareId: device.hub.hardwareID])
}
else {
log.warn “ON/OFF REPORTING CONFIG FAILED- error code:${cluster.data[0]}”

Still had some errors popping up. Going to abandon and go with another route unless you can share your git code instead of copy/paste here.

ranman916 Here’s a link to the file. It is open to the public and I’ll delete it after you download it. Let me know if it works. Good luck.


image

1 Like

Success! Thanks!

Does this controller act like a repeater?

I asked Gledopto.

Grtn Ben

I wanted that, no repeater functionality, that way it will not repeat my Xiaomi sensors and meme the offline. Thank you for the help.

hi,
i try your code te uploaded but my color temperature can be changed only from 0 to 100 K.
did you know why?

Smartthings has a limitation on the app that displays the LED controls. To get around it, Use Smartthings CLASIC
Add a Scene.
Select the LED
Next
Name the scene : Real Warm Light
Click ON
Click the “>” - Device Set Up
Select + “add device Options”
Select COLOR Temperature
Move the slider to the temperature (2000 is warm white)
Select Brightness
Move the slider to the brightness (50% to 100%)
Select “DONE”
Select “DONE” again
Select “SAVE”.
Select the Scene and it will set the LED strip to the Color Temperature you have defined.
Go to the New Smartthings. It will show the new 2000K temperature. However as soon as you move the slider it will only go to the 100K. Run the scene again and it will go to the 2000K or whatever the scene is defined.

I should read my own notes. See the Jan 28 reply. You need to use the NEW Smartthings app. Create a scene with the LED, select the LED, it brings up the options, select ON, then Color Temperature, type in 2000, then DONE, the select Dimmer, set at 50% to 100%, then DONE, then SAVE, name the Scene, then SAVE. Run the Scene and it has Warm White.

gledopto cannot work with IKEA now…

Different lights, the wiring should be different…