GitHub login broken?


(Zpriddy) #1

I don’t know if it is just me… But I unable to login with my github account… When it redirects back to the st website I see a URL mismatch error in the URL path… I would post from my computer with a screenshot… But I’m stuck only using my iPad…

Does anyone know anything about this?

Thanks!


(Edward Pope) #2

I am able to log into my account, have you tried another browser on your machine? Or another machine?


(Zpriddy) #3

I have tried 3 browsers… But it’s a clean install of the OS so it’s the first time authenticating…


(Sam Saffron) #4

is this only happening from iPad?


(Zpriddy) #5

No this is from my Mac. The iPad is the only thing I’m still logged into…


(Zpriddy) #6

This is what I see…

https://community.smartthings.com/?error=redirect_uri_mismatch&error_description=The+redirect_uri+MUST+match+the+registered+callback+URL+for+this+application.&error_uri=https%3A%2F%2Fdeveloper.github.com%2Fv3%2Foauth%2F%23redirect-uri-mismatch&state=XXXXXXXXXXXXXXXXXXXXXXXXXXXXX

(Sam Saffron) #7

Confirmed, both GitHub AND Google callback urls are pointed to HTTP instead of HTTPS

@Ben @April this needs to be fixed urgently on your side (we don’t have access to these settings you configured them)

@zpriddy workaround while stuff is sorted, do a forgot password on your email.


(Ron) #8

What github login ? I know it was promised that the ide would integrate with github but I don’t think it does right now ? This has me curious …


(Ben Edwards) #9

@Ron This is different. Github integration with the SmartThings platform is imminent.

This issue is signing in to these forums using your Github “connect”. Working on it.


(Ben Edwards) #10

Ok - I think I have Github and Google updated. Let me know if you see any issues.


(Zpriddy) #11

This is now posted with my Mac! :slight_smile: You guys are awesome! Thanks!


(Ron) #12

Ah…that makes sense…I forgot that existed I used google :smile: