GitHub Integration - updating and publishing


(John) #1

I have two apps (Rule Machine and Alexa Helper) using GitHub integration. If I hit “Update From Repo” I will then see:

My question is, in this state, am I now updated? Or do I now need to go into the two SmartApps and click ‘Publish’?

Thanks!


(Brian Diehl) #2

When the pop-up comes up for Update from Repo, there is a checkbox in the bottom right corner for Publish.
Check that before hitting Execute Update and you are fine.
Otherwise, yes, you need to go into each and Publish for Me.


(John) #3

Thanks for the clarification!

Would it be advised NOT to hit the check box for publish on Alexa helper, seeing as the child app should NOT be published?


(Brian Diehl) #4

You can either do that and then go in and publish the parent app from the IDE.

The other option is to update via GitHub Repository one at a time and publish the parent app, then skip publishing the child app.

It really comes down to personal preference. If you’re worried you’ll accidentally publish the child app, then don’t use the publish on either. If you trust yourself enough to check before clicking through too fast, then you should be fine.

Both ways take roughly the same amount of time.


(John) #5

Got it, thanks @diehllane


(Marc) #6

I publish both Rule Machine and Rule and publish both and have never had a problem. Why is it bad to publish the child app? I thought it was just for aesthetic reasons?


(John) #7

I’m specifically talking about the Alexa Helper App. In that SA, Michael specifically sates not to publish the child app. This is a different scenario than Rule Machine.


(Mike Maxwell) #8

It depends, there is no problem publishing the child, once published though you always need to publish it in the future.
There have been times when the child in the IDE doesn’t update the mobile app, so Bruce changed his stance on it.
I have had this happen to Apps I’ve written as well.
Doesn’t happen often, but when it does it’s a bugger to figure out.
You’ll also notice that several of us are or already have including app version displays in the apps to help with these and other issues.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #9

Yah… I wish this were built into the platform (i.e., all SmartApps should have an “About” page that the Developer outlines in the definition{}.


(Micheal ) #10

I should clarify this…there is nothing wrong if you accidentally publish it…it should have no effect on performance. However, I recommend not publishing it just as a matter of course as it does clutter and confuse some users when they see the child app as a valid selection in the Marketplace but click on it and find it doesn’t work.


(Brian Smith) #11

Is it possible to link a repo to a smart app I copied in there manually to begin with? I have been using @ethayer’s excellent User Lock Manager for a long time. I added his repo, ethayer/user-lock-manager, but it is not allowing me to update it. It also says “file not found in repository” when I roll my mouse over the smart app in the IDE…even though it is copied and pasted straight from that code.

So, am I doing something wrong?

It would really suck if I have to delete the SmartApp, add it again and then have to add all the settings back.


(John) #12

I never had to delete anything I did manually, at first. When I hit update it finds it, checks the boxes and you hit update. Are you sure you have the owner and path correct?


(Greg) #13

When I added repos for apps I already had manually I ran into the same issue. Go into Edit app properties and Edit source code. Then pick the right repo. That fixed it for me.


(Brian Smith) #14

Yeah, I have the repo attached to it if you check out the image above, but it still doesn’t show anything as an option. :frowning: