SmartThings Community

Ghost zigbee devices - can't remove them!


(Hammster) #1

I have tried contacting support multiple times both via email and via phone. They have yet to respond to my emails and it’s been 11 days - I have opened four cases at this point. I can only conclude that email support just isn’t a viable option at this point. Phone support I just wait on hold! I hung up after an hour of being onhold!

Here’s my dilemma. I purchased a Smartthings 2.0 hub to replace my old Smartthings 1.0 hub.
I used the “Move Devices” option to move my smart things from the 1.0 hub to the 2.0 hub.
They appeared to move correctly. However, now they just say “Loading status” and are inaccessible. When I tried to remove them, the “Delete” button wasn’t even an option for them.

I eventually hardware reset the 2.0 hub and tried to start over from scratch without moving anything, but they reappear! They do not appear however when I login to account.smartthings.com

Does anyone have any suggestions on what I can do?

Thanks!


(Fernando Fuentes) #2

When you loging to your ide make sure you are in the right “Default home”
I had a smilar problem but it was multiple homes that were some how created. They go in to read only mode and cant be deleted until I change the default home.

Are you using the New App or the classic smartthings app?


#3

Ouch!

We would need to know the exact brand and model of the devices in order to help untangle this.

Unfortunately, hub migration is not what the “move devices” feature is for. It does not transfer zwave or zigbee devices from one hub to another.

Instead, it transfers a hub and its devices (except you have to individually select them) from one “location“ to another.

This is why we need to know the brand and model. If you only had devices with cloud to cloud integrations, like, say, LIFX bulbs, they weren’t directly connected to your V1 hub anyway, so there’s more that can be done.

But if you had devices that were directly connected to your V1 hub, they are going to have to be individually reset and then individually added to your new V2 hub.

Which, yeah, sucks, but there is no migration tool even though they have been promising one for a long time.

I’m not feeling well today, so I’m going to have to leave it to other people to help you through all the details. But let’s start by getting the brand and model numbers of the “ghost” devices.


(Hammster) #4

I created a new home location “Home 2”, switched it to default, and then deleted “Home” - thinking that somehow the ghost devices were attached to the Home location.

However, they still reappeared when I added the hub to the app. They must be attached to my account somehow since I did a reset of the hub.

I am using the new app.


#5

This is the community FAQ on the multiple locations issue. Some of that maybe mixed into this situation as well, but again, “move devices” will not transfer a zwave or zigbee device from one hub to another. That’s a different process.


#6

They are attached to your account, but they are probably attached to your account as still belonging to your V1 hub. Depending on the exact devices, of course.


(Hammster) #7

The ghost devices do not allow me to delete them - the “Delete” button isn’t even found. Interestingly, they are all Smartthings branded devices.

Here are the ghost devices:

Smartthings Gen1 Multisensor 3300-s
Smartthings Gen1 Multisensor 3300-s
Smartthings Gen1 Motion Detector
Smartthings Gen1 Motion Detector


(Hammster) #8

I went through the power cycle reset for the old 1.0 hub and tried reentering the welcome code but it is now saying it is already in use. Smartthings was unable to remove them from my account and elevated my ticket.


(jkp) #9

Not that this will work but try changing the Home Location in the Classic app.


#10

OK, those are zigbee devices, and they still belong to your V1 hub.

Is your V1 hub still on your account or is it just gone?

In any case, you are going to have to individually reset each sensor physically to factory settings and then individually add each one to a hub which is on the same location in your account as the sensors.

Also, you may have to enable “insecure rejoin” for the duration of this migration process.


#11

You probably can’t delete them because they are devices that belong to a hub (your V1 hub) which is no longer talking to them. So smartthings doesn’t know how to remove them through normal communications.


(Hammster) #12

Just an update - I tried to reset one of the Zigbee devices (the multisensor) by removing the battery and reinserting it. However, the 2.0 hub was unable to find it. I await further instructions from Smartthings support.


#13

Did you follow the instructions for that specific model? For the multi sensors, you have to hold down the contact button at the exact same time that you re-insert the battery or it won’t reset. (Otherwise you would never be able to change the batteries in the sensor without losing it from your network.)