Ghost "Things" - Any ideas?


(Never Trust @bamarayne) #1

For about a week, couldn’t access “Things” from the ST app… no idea why. The latest app is doing alot better.

However, I have some Things that are displaying as follows:

Now when I look in IDE, I don’t see any devices without names, etc. Anyone else ever have this?

I can sit down and do a item by item comparison and eliminate each one (IDE to ST App) and possibly determine which ones need to be forced deleted and rebuild them - and I probably will if there isn’t a better way.

However, this is an example of… holy crap… a lot of work to chase down ST issues.


#3

I don’t have smart home monitor installed, but is that screen capture from inside SHM?

If so, the first thing I would do is try to determine if the things are displaying OK on the things detail page under my home to see if the problem is only with SHM itself, or with the device description in the database.


(Never Trust @bamarayne) #4

It’s from the ‘Things’ view… not SHM.

I created a spreadsheet and combined IDE data with ST APP data and through the process of elimination determined it was two keypad devices I could not remove awhile back that I had named differently so they would be at the bottom.

Somehow they have been relabeled ‘Preferences’ which puts them there in my Things list, but oddly with the ? marks instead of any name or details.

I cannot delete them from IDE: I get the following:
× org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: script14615311151211441851.groovy: 1: expecting ‘/’, found ‘\n’ @ line 1, column 4. /** ^ 1 error

When I tried to edit the device, without changing a thing and clicking update it throws an error as well.


(Stuart Buchanan) #5

I get the same in my things view on Windows Mobile, the devices with ? Are all hue Re-Connect Scenes and the Hub. Was gonna look into why but I’ve just not got around to it


(Bobby) #6

There were warnings from ST folks about Hue reconnect app that will stop working without updating the code. You may want to follow up on that thread…


(Never Trust @bamarayne) #7

Support removed them for me.

Thx


(Bobby) #8

Why is ‘My Home’ called SHM? I see why @JDRoberts thought it was SHM.


(Never Trust @bamarayne) #9

I just caught that. Not sure why it displayed like that. Clearly an app error.

Was in home, things.


#10

Tagging @slagle


(Never Trust @bamarayne) #11

Note that my situation was not hue.

Old centralite keypads I could not delete.

I had hidden then through labels, but the labels changed.


(Bobby) #12

This is the one I was talking. @Fuzzyligic said he has issues with Hue. While it may not even be related, as it seems like the hub would fail if not updated, is always good to keep sharing important updates…


(Stuart Buchanan) #13

@SBDOBRESCU yup I did the pull request for it. It’s been changed already. The issue I have doesn’t stop the devices from working, they work fine. Just don’t display in the app now but when you click on the ? You still get to the device where you can still turn on the scene