Geofence Stopped Working on iPhone

I upgraded latest iOS today. No change. Still have to leave the app open and it works…

Regards,

Bill Wolfe

If you can’t beat 'em, join 'em! I know this is a brutal hack, but let’s try using an IOS shortcut to keep the app open when leaving the home location. In my case, I’m using an iOS shortcut (considered an automation) when I connect to Bluetooth in mine or my wife’s car. This simple automation opens the SmartThings app. For safety’s sake, I will also create a location based shortcut when I leave and arrive at home. All this just to keep the app open. Here is a link to the Apple shortcut stuff: Setting triggers in Shortcuts on iPhone or iPad - Apple Support

I know, grrrrr!! Hopefully this gets fixed by Apple, soon.

Good idea! Thanks!

Interesting tidbit… ST now knows when I leave (with app closed) but doesn’t know when I return (with app closed).

What was the solution ? I can’t see the reply you are referring to. Please help I’m also lost.

I haven’t found a solution. The only thing that works is leaving the app open and geofencing works.

Very annoying and frustrating.

Regards,

Bill Wolfe

Apparently iOS 15.3 will fix this issue. It’s out in Beta now.

I sure hope so. My Arlo geofence has stopped too now… VERY frustrating.

Regards,

Bill Wolfe

It looks like iOS 15.3 does solve this problem!! (But I’d want to do more testing to be certain…)

Updated last night - ST did execute this morning when I left!!!

1 Like

I’m having a geofence issue now too. I’m use a Samsung Galaxy s20, and a few days ago all of my home/away automations we’re working fine, and now they aren’t working at all. Is there an update or change that I missed?

Tested several times today. All seems well on iOS now. What a frustrating time this has been.

Regards,

Bill Wolfe

The Android app updated last week. There are now a lot of us wondering where our presence sensing has gone.

The only thing I can offer is my iOS and geofencing hasn’t working for several months (until yesterday) unless the app was open. Have you tried leaving the app open to see if it works? I ended up setting up shortcuts to open the app when I left and returned (I can’t take credit for that, someone else had the idea).

Regards,

Bill Wolfe

Glad it’s not just me, I guess. Hopefully, they fix it soon.
Is it possible to go back a version?

It can be done, but users have reported a new version of the app is being rolled out so it might be worth holding out for a day or two in the hope that includes a fix.

They moved it to iOS. Can only have it functional in one platform at a time. :slight_smile:

This thread is for iOS devices (iPhones and iPads). Bixby routines are not available on those, so unfortunately your method will not work for the people in this thread.

I know this thread was originally an iOS thread but it did bring in Android later and there are a number of links here, so …

The use of Bixby Routines has been mentioned recently, in particular because of the ability to react to connection and disconnection from Wi-Fi and completely eliminate the dependence on the geofences. Sadly Samsung don’t seem particularly interested in supporting Bixby Routines on lower end phones.

Google Home ‘away’ detection seems to use a significantly bigger geofencing radius than the ST minimum, so if you use that minimum it lags by a minute or two compared to ST. I also understand it waits for Nest devices with sensors to report inactivity though that isn’t a factor in the configuration I use. With one phone the ‘away’ simply doesn’t happen. With others it usually does. I find it OK to provide a departure backup, but actually ST is rock solid for my home anyway (except when there is a genuine fault).

As for the ‘home’ detection … hopeless. Unless it is using a different geofence for arrival I’d rather expect it to beat ST to it as often as not. At best it changes in the same minute. More typically it changes a few minutes later. Sometimes it waits until the Google Home app is opened. Other times it doesn’t bother at all. It is barely useful as a backup as it just lags too much.

1 Like

There Are quite a few community members who also use home assistant or have experimented with it.

But to be honest, for the purposes of this thread, which is in the iOS section of the forum, by far the easiest thing is just to get a $10 Meross WiFi smart plug which will be visible to both Apple HomeKit and smartthings. That’s all you need as long as HomeKit presence is working, and generally historically it has been the most reliable since it is built into the iOS operating system. You just have Apple presence turn it on and its turning on will be visible to smartthings. Essentially the iOS equivalent of Bixby routines. :sunglasses:

How to Use a Meross Plug to Use HomeKit Presence to Trigger ST Routines

There are at least a dozen different topics in the forum on presence, I don’t think we have to try to shove everything into this one. Particularly since there is such a simple solution for those with iOS devices.

You can find the other topics on presence on the following quick browse list:

Topics tagged project_presence

Submitted with respect.

1 Like

Nice! Thanks for sharing that solution for iOS!

1 Like