Gentle Wake Up

OH right. It’s in SmartThings now. Thanks.

The Contact Book bug fix finally went out today. Can you confirm that it’s no longer required for you?

All looks good. Thanks.

is this thread still active? I am having issues using Gentle Wakeup with Lifx. the controller always forces a Purple light!. This is a real issue for me. any thought on adding color control?

SmartThings color support was based on the original Hue bulbs. They’ve never added a color space correction feature, so other brands always end up off-color. I have several Hue and one LiFX in a room, I’ve been bugging them about this for some time now.

1 Like

Does it turn purple even if you have the change color option turned off? Or just when you have GWU set to change color as it dims (which is the default setting)?

If it only turns purple when you have it set to change color as it dims, then it’s an issue with the device type handler (sort of). I only have Hue bulbs so I figured out the values to send based on those and I haven’t looked back.

Maybe I’m missing something but I’m trying to figure out how to use GWU to mimic a sunrise alarm - is there a simple way to do this? I couldn’t find any option to start ‘dimming’ (or increasing in intensity, for context) lights when sunrise occurs…

EDIT: NM - I didn’t realize there was an actual device that gets created. I forgot to add the device handler :slight_smile:

I have had GWU for sometime now. I use it to dim a bulb from 0 to 99% over 30 min. At the end of the dimming it is supposed to turn all the bedroom lights on to full brightness, set the house into “home” mode and push a message saying “Wake up!”. The dimming is working properly, but the end activities are not. The bedroom lights turn on to full brightness, but the mode change and push message never occur. I am not sure when this started happening because I had just assumed that my husband had cancelled the message and it wasn’t until we recently started using the SHM that I realized that the mode wasn’t being changed.

I have tried deleting the app and handler and tried a fresh install, but nothing seems to be working. I was wondering if anyone else has encountered this issue or any advice as to what might be going wrong. Thanks!

I had the same issue and finally gave up. I moved to Lifx bulbs and now leverage the same functionality in the Lifx app…

I’m trying to pull the status of all my ST to a web page and I can get the status of all my switches and the status of the Gentle Wake Up things as well as their percentComplete. I can’t seem to get their timeRemaining as I just get an erorr and I don’t know how to get the original timer value to calculate it.
I guess I don’t understand the inheritance from timedSession? How can I get the actual time remaining?
Thanks!

Mike whats the use case here? Dawn and dusk for aviary or green house perhaps? I have a similar need…

The web page use case?

  • all my lights, room groups, relays, TVs, timers, music, etc. in one place instead of spread across multiple apps, custom apps, etc.
  • ease of use for the GF because she sure doesn’t want multiple apps, etc.
  • easy of use for friends that stay over so they don’t have to install anything; just touch an NFC tag and it launches the web page
  • only real way I know to easily integrate things that are ST with things that aren’t: like my xmas chromecast playlist for the chromecast audio group or for slideshows on the TV

The Gentle Wake Up use case?

  • I am currently using it to run a 15 minute countdown for the night lights in the MBR
  • I will do the same for the guest bedrooms
  • These timers are all started by hand at the moment (and always?) because we don’t go to bed at the same time every night

Pulling TimeRemaining from Gentle Wakeup use case?

  • so I can display on the webpage how much longer before the lights go out (overall this is not Super necessary but I thought it would be “easy” and now I want to figure out why it is not “easy”)

I just got started with ST so I definitely don’t have a great grasp on how the currentValue() function works or how all the parent / child relationships work.

I have installed personal versions of the smartapp and devicehandler for Gentle Wake Up but I still don’t get it :slight_smile:
Maybe looking inside TimedSession would help but I don’t know how to do that.

I wonder if something is wrong with the original smartapp because trying to get currentValue(“timeRemaining”) returns java.lang.NumberFormatException.

While currentValue(“foo”) returns null.

So timeRemaining is there I just can’t get it correctly?

Or do I need to cast or override the format? The docs say it is a number.

Hi there! I’m having some problems with Gentle Wake Up - the lights will change colors, but they won’t dim. It happens on both dim from 0 to 99 and from 99 to 0. They just turn on and stay at the level last used. The light is Osram Lighity A 19 bulb.

PS. If I turn off the color changing option dimming will work.

Also, I scheduled Gentle Wake Up to run every weekday, but I don’t see how I can turn off the schedule for holidays or days when I’m sleeping in. I see that routines can be set up not to run in a specific mode, but don’t see that option here. I added a “Sleeping In” mode, hoping I can prevent Gentle Wake Up from running when in this mode.

Thanks!

I think turning off the ‘color change’ option is the only way to make the osram lightify bulbs to work as an automated dimmer.

The only way to turn off the app is to remove the time to run portion of the rule. You might be able to create a new ‘mode’ in the ide for an away mode, or a vacation mode, but im not sure if its possible or not as i haven’t tried that.

Thanks, I’ll try that.

I thought that the gentle wake up works similar to a switch and used it in a core piston as below.

If Wake-Up changes to "Off"
Then Set Color temperature to 6500K

But the Wake-Up changes to “Off” is always false. Can someone help me how to get this working?

Hello, just started playing with this app. Using with the color Hue and it seems that the default turn on color is a blue-ish. I cannot see an option in the smartapp to pick a color. I would like to use red, is that possible or programmable?

2 Likes

I have tried a couple of times to Dim a bulb in my daughters room from 99 to 0% over 60 minutes. for some reason it only goes to 17% and then claims to have finished dimming. It is an Osram Lightify bulb being triggered by the controller app.
Anyone have an idea why this behavior or how to correct?

1 Like

I’ve run into issues trying to set it to 45 minutes. It gets to 15 minutes left and then jumps to the end. My guess is the code isn’t designed to work above 30 minutes.