Gentle Wake Up

smartapp_lighting
troubleshooting

(Rusty) #1

I’ve been trying to get the Gentle Wake Up app to work and having some difficulties, or I’m not understanding what it’s trying to do.

I get it to start at the set time and brighten for the set time, say 10 min. After that it dims al the way back down and starts all over again. Am I missing something? I thought it would just stay at full brightness after that point.


ST support not supporting ST apps?
(Steve) #2

I hadn’t noticed that. I only let it execute during a specific mode and then have it change modes when it’s done. So it never repeats for me, but I bet I know what’s going on. I’ll do some testing this weekend, and see what I can figure out.

Thanks,
Steve


(Rusty) #3

Thanks! A couple of other things I noticed is if I set it for a duration of 15 minutes, it takes about 21 minutes. Then it shuts the light off, then the app does the wake up again, but it takes longer. I’m trying to use it with the GE/Jasco 45602 with a bedside lamp. I was going to get a dimmer to control the overhead light to see if it’s just the type of dimmer or not, but haven’t had a chance to get one.


(Alex Christensen) #4

I’ve had no luck with that app. Sometimes it took over 2 hours to come to full brightness, when set to 20 minutes. I bought a Hue set and use it’s build in timer for my wake-up light.


#5

I am having the same issues with this app.


(Steve) #6

I have a new version that fixes the timing issues. I ran it 20 times in a row when testing it with each time set to take 30 minutes. 2 of the runs took 34 minutes while the other 18 took 30 minutes. I’ve been using it every morning for the past few weeks and haven’t gone more than 30 minutes yet.

I haven’t published it yet because I’m utilizing features that weren’t available in the iOS app until version 1.5.4 which became available Monday. There are many things I still want to do with Gentle Wake Up, but those will have to wait for another iteration. The last thing I need to do in this iteration is to test updating from the current production version to this new version to make sure I don’t break anything.


(Steve) #7

Well, it took longer than I had hoped, but I finally published my updates today. You can read about all the improvements on my project page: http://build.smartthings.com/projects/gentlewakeup/


(Cory S) #8

@steve_vlaminck Is there a way to abort the app from running easily after it starts? A couple of examples…I wake up and want to turn the lights off so they don’t wake my wife…but turning the switch off only stops it for a few seconds. Or, it’s a vacation day and I don’t need to get up for work, and forgot to disable the app.

Ideally, if the app would subscribe to the switch and stop after any physical input on the switch is detected that probably work perfectly.


(Steve) #9

Yes, there are a couple of things you can do.

  1. You can go into the ‘Apps’ section and press the play button on the tile. The play button will toggle The cycle. So start if it’s not running, and stop if it is running. screenshot

  2. In the same way, you can press the play button in the right tray. To find this go to the ‘Things’ view, and tap the gear on a device that Gentle Wake Up is dimming. Then tap the ‘SmartApps’ tile to open the right tray. screenshot

  3. You can also stop it using mode changes if you have Gentle Wake Up start when entering a specific mode. screenshot

Let me know if you have any problems with any of those.

edit:
Actually, the play button may not be enabled until you go into the SmartApp and hit “Done”. That will create the subscription necessary to add the play button to the tile… I didn’t think about that when I updated the app.


(Cory S) #10

I have the play button. The update actually broke my Gentle Wake Up configurations, so I had to reinstall them :P. It’s good news to hear they are they are toggle buttons though.

I guess the best way to set it up would be to have to disable itself when the mode changes from night to morning when motion is detected.


(Cory S) #11

@steve_vlaminck Hmm, the app didn’t go off again this morning. After the app was update I don’t see the checkboxes to control which modes the app can be active in. There is a new radio selection box where you can chose one mode, but that is worded as if it that mode will fire the app regardless of the time settings. It also only allows you to select one mode, where as I would want mine to go off in every mode but away.

Am I missing something?


(Steve) #12

That’s an oversight on my part. I didn’t add the ability to only allow it to fire in specific modes. I’ll be sure to put that back in.

As for the mode selection that is in the current app, it does fire when entering that mode. So if you have a Hello Home phrase that changes your mode, that mode change will start your dimming. This is how I use it, btw. I can make that a multiple:true element, but I’ll need to test it a bit before publishing it. I’ll especially have to think about how the exit modes work.


(Joe Geiger) #13

I had success in using it to dim the lights when I go to bed. The successful part was it dimmed for the duration I had set. The unsuccessful part was that it only turned off 1 of 2 bedside lights so I had to manually shut the other one off. I’m using Hue bulbs and am wondering if it’s due to that or if it’s a problem with the app.

I also noticed the activation time was off. I was playing around with and testing it over the weekend and noticed when I set the begin time for 10:04 am and pressed Done, it showed up in the app as 2:04pm. I then set it 4 hours earlier (6:07am) and it triggered properly at 10:07am. Maybe it’s not reading the proper timezone.


(Steve) #14

Hey Joe,
I’ve had issues with Hue bulbs not receiving commands before, but haven’t seen it in a while. I attributed it to the sheer number of commands being sent, and the flood of traffic on the network. That being said, it’s not an acceptable answer. And now that I think about it, I execute a Hello Home phrase in my completion actions. I bet that is always sending an off command to my lights which could explain why I never see it. I’ll do some testing, but please let me know if it happens again.

As for the activation time, you are exactly right. I build that string manually and neglected to account for timeZone offsets. I published a fix for it yesterday so it should be right if you look at it now.

Cory,
I’ve been testing with QA this morning, and we’ve seen a few exceptions thrown when the schedule starts. I’ll keep you posted with what we find. Do you by chance use an Android phone?


(Cory S) #15

@steve_vlaminck yes, I use Android phones. Thanks for looking at into it for me.


(Steve) #16

OK, I hope I have it fixed for you then. We found a bug that we were only able to reproduce using an Android phone. We don’t know if it is actually related to Android or if we just happened to be using an Android phone when it happened, but in either case we haven’t been able to reproduce it since. Let me know if your schedule fails again.

Joe, I think I have a fail-safe in place now in case your light misses the last setLevel event. Let me know if it doesn’t work for you.


(Cory S) #17

@steve_vlaminck It partially worked this morning. One dimmer came on, but the other did not. Also, I noticed a bug where if you select a mode to enable the app, you then cannot ever unselect it. You have to select another mode, or the change doesn’t take effect.


(Justroach) #18

The options to cancel the alarm seem to have been broken with the 1.6.x “update”. Are there any new ways you might be working on to allow the alarm to be canceled? Thanks for the great app!


(Brian) #19

I have the same issue all the time. My girlfriend wakes up after about 25% light and wants to go turn the light on all the way and it ends up freaking out.
Im going to work on modifying it myself by having the app listen to the device events, and if it sees an event of on/off then it will abort and fire the requested event instead.
@steve_vlaminck do you see this being feasible?


(Steve) #20

That seems like a reasonable solution. Shouldn’t be too difficult, either. I imagine you’re thinking about subscribing to dimmers and setting atomicState.running = false if any of them are turned on or off? I think that would be all it would take, but you’ll have to do some testing.

I don’t think you’ll need to send any commands to dimmers though. They should react however the physical switch told them to. I also don’t think that you’ll receive any on events because dimmers will already be on as they are dimming. So in your scenario, the user will have to flip the physical switch off to cancel it and then on again. But in the scenario where the lights are dimming down, turning them off at the switch should be all that’s necessary. I might even go as far as to suggest only subscribing to dimmers.off for that reason and for the sake of easier explanation of the UX. “To cancel the dimming of your lights, simply switch off any of the lights that are dimming.” Something like that. You might also want to call down(100) if direction == "down" so that all of the lights shut off.

Make sense?


New App: Gentle Wake Up With Smart Weather!