GE Z-Wave Dimmer - Smart Lighting not setting level

Still no ETA on this fix?

Affected so far is:

  • GE Dimmers
  • GE Link Bulbs
  • 2GIG Dimmers
  • Linear Dimmers
  • Evolve Dimmers
  • Lutron Dimmers

That’s pretty much everything. This really sucks, the big hype for v2 was local processing. Most of us install dimmers in every case possible. That said, this bug makes v2 sort of worthless.

There doesn’t seem to be much movement. I really hope everyone reading this thread opens a ticket.

1 Like

Hi Folks,

Just wanted to chime in and say that I am also experiencing this same problem. I’ve got a GE Dimmer with smart lighting set to turn on and set level when turning on the light to different levels based on mode. So for example, if the house is in:

Day: 80%
Dawn & Dusk: 50%
Night: 10%

The rules all do run upon activating the light, but the level always stays to whatever I set last manually via the thing interface. So it looks like I’m in the same boat as everyone else. Hopefully they’re working on a fix for this. One question I had though: If you develop your own smart app, do you have control over whether not it will be run locally vs in the cloud? I’m an engineer professionally and would consider tackling writing a smart app to run locally if it’s possible. I’ll try to dig further into their developer documentation to learn more? But was curious if anyone has already played with it.

I’ll throw my voice into the mix and say I’m having the same issue as others on the thread. Please fix! Is there a technical reason that is making this difficult to fix? For the meantime, going to try SmartRules as a workaround.

They’ll just mark it as solved and close it. (#133647)

1 Like

Yep, here you go.

The reality here is if the community of user developers didn’t exist this platform would be dead in its tracks. This is core functionality, ST is riding the backs of it’s customers to bridge the gap. I work in this business, there isn’t an ETA because we (the users) have created our own workaround which allows them to continue to de-prirotize these types of fixes. If we didn’t have a workaround the monkey would be squarely on ST’s shoulders and they’d had it fixed back in September.

That said, all of us are to blame for this. We can stop developing on our end until they fix critical issues or we can continue to whine about broken functionality because we bailed them out with some janky fix. The former probably won’t happen so the latter will continue to persist.

I will no longer contribute solutions of any kind to this community until ST gets their crap together and stops taking advantage of us. The same actions from a few critical folks would send a good message especially as they onboard new users who will add to the chorus.

Kyle (SmartThings)
Dec 31, 12:56 PM

Hi Glen,

Unfortunately I don’t have an ETA to offer on this. I know it’s frustrating, and I apologize for the trouble. Please bear with us though, SmartThings is working on it, I promise.

Best Regards,
Kyle
SmartThings Support

Glen McGowan
Dec 31, 12:38 PM

What is the estimated ETA? Can you give me a projected month? Quarter? Year?(!).

Per the SmartThings community this has been an issue since at least September. Most people install dimmers, if I can’t dim it’s fairly useless the me.

This is a critical bug. Not sure why it’s not a higher priority.

Kyle (SmartThings)
Dec 31, 10:23 AM

Hello Glen,

Thank you for the feedback. Unfortunately this is a known issue that our developers are working on implementing a fix for. I’ve tagged your account to receive automatic notification once there is a solution for it. Until then, my apologies for any inconvenience this is causing, and thank you for your patience.

Best Regards,
Kyle
SmartThings Support

Glen McGowan
Dec 31, 3:11 AM

Hello,

There seems to be a bug with the SmartLighting App which ignores set level requests when creating lighting automations. Lighting triggered by motion or other actions doesn’t dim to the requested level defined in the automation created.

Devices affected so far:

GE Dimmers
GE Link Bulbs
Lutron Dimmers
Evolve Dimmers
2Gig Dimmers
Linear Dimmers
Thanks,
-Glen M.

1 Like

For what it’s worth, a relative of mine bought a whole pile of the OSRAM smart bulbs. They dim flawlessly via Smart Lighting with and without motion triggers.

I watched in complete awe as they dimmed with out hesitation. So frustrating…

@btk If you have the time and/or the inclination, try giving this a test.

  1. Create a smart lighting rule with your desired light.
  2. Set to “On & Set Level”.
  3. Dimmer Level 30%.
  4. Set trigger to open/close and select a contact.
  5. Turn on and Set level when door/contact is open.
  6. hit done a few time to create rule.
  7. Open the door.

The light should dim correctly in response to the door open. Now close the door…

  1. Update the rule (do not delete and recreate!) to remove the door.
  2. Add your motion sensor, etc.
  3. Hit done to save.

The light should dim correctly in response to motion. I’m curious if this works for you.

I don’t think it is dimming in general broken dimming works fine from the device type in the app or from many smartapps … It DOES not work from the smart lighting smartapp and I think that is the bulk of the issue.

too bad the smartlighting smartapp is not one of the public templates or I would fix it for the @$$.

It works from the Smart Lighting app if you follow my steps above. At least it works in my case, local automation and all.

The key seems to be to create the rule first with some trigger like a contact sensor, then edit the rule to add motion. Dimming seems to work correctly after that.

Even if you could create a copy from template, the modified app wouldn’t run locally per their design. In which case it’s not any better a solution than Rule Engine (in terms of running local).

I’m using GE Dimmers with Aeon Multi-Sensors and dimming doesn’t work unless I use the steps above. My cousin on the other hand has the same GE Dimmers with an Iris motion sensor and his Smart Lighting dims correctly without the above steps.

Whatever the issue, it’s very specific…and annoying.

Not in my case it doesn’t. I am not trying to dim on motion but dim at a certain time.

Very interesting! I can’t wait to try this when I get home this evening. I’ve got a door sensor I can use to set up my lights before switching over to motion. Kind of an annoying workaround, but it’s better than using rules engine if it still runs locally. If this works, you get my hero of the month award.

1 Like

It works!! Well, mostly. It did not seem to work if I triggered the light automation via door open/close sensor. But then I tried triggering it via hitting a virtual switch, and that correctly turned on and set the light to the correct level. I then edited the automation to use motion instead, and it now works correctly via motion - yay!

One thing I just realized is it seems to take a couple hits of the virtual switch before the light automation starts working, so maybe if I had open and closed the door a few times more that would have worked, too. A virtual is just quicker since I don’t have to physically walk back over to it.

I also found I could do this fix by editing my existing rules and switching from motion to virtual switch and back to motion. Nice that I don’t have to recreate everything.

It’s so weird that this works. What in the world kind of bug in the hub is fixed by such an odd process? Regardless, I’m just glad to have my auto dimming back!!! Woo!!

You definitely get my hero award of the month, @mobious! Thanks!

@brbeaird I’m glad it works for you, I’ll wear the award proudly!

It certainly wasn’t my intention to provide a solution. I simply wanted someone else to confirm my results so that I could probe the limitation further in terms of how it affects my own system.

I would ask that you still open a ticket, even if they close it. Hopefully there is some internal metrics reporting that drives fix priority. Maybe these steps outlined above will even provide further clues and speed up the fix. Assuming they read every post as they claim to do.

Thanks for reporting back your results and even taking further steps to try the same steps using a virtual switch (I didn’t think of that).

1 Like

Ha. Yeah I’ve had 3 separate tickets opened and closed for this issue already. I do plan to respond to the last one with these details, though.

1 Like

How do you set up a virtual switch? I tried the door thing and it did not seem to work. The door would trigger the light on to the last dim level that the light was on at.

There’s a good list of steps in the link below. When choosing the device type I personally go with the “Momentary Button Tile” instead of the “simulated switch.”

Okay, when you use the virtual button the action get pushed to the cloud.

Set level works from actions when they run in the cloud, they do NOT seem to work when running locally on a V2 hub.

Interesting. So the workaround of the virtual switch basically moves the entire rule to the cloud, and switching it to use motion after that doesn’t cause it to switch back to local, so it continues working at that point. So the bottom line seems to be that any locally-initiated action is NOT able to set level.

I got the e-mail yesterday saying an update would be pushed to my hub on Thursday. Is it too much to hope this is fixed in that update?

…and yet another clue.