GE Switch Failures

I’ve had two out of three GE12722 Z-Wave switches fail on me. By fail, I mean that their z-wave functionality just dies. They don’t respond to commands, don’t respond to z-wave network repairs, won’t uninstall – just dead to the z-wave world. Seems like a high failure rate.

Anyone else seen this?

I had about 15% bad unit DOA when I purchased a bunch from Lowes last year. Since then I have no physical failures, but one or two fall of the network each month. I first power off/open the air gap, then restore power. If that does not put it back on the network, I then use Hub utility Z-wave exclude (press the switch during the 15 second exclude period), then search for new devices within the mobile app (press the switch again), and re-include and transfer all the dead switch smartapps to the “new” switch, then delete (force) the device within the switch’s preferences.

It happens so frequently that it does not bother me anymore. I assume an issue with the GE switches but could be a ST platform bug as well. Always seems to happen when platform changes pushed out and weekends! Last happened Sunday to one switch, and 10 days before that to another…

The prior generation had a known issue that required a hard reset ( turn off at the breaker box). Not just ST, Homeseer and Vera users reported the same issues.

I thought that was fixed with the new generation, though.

This might be the prior generation, because I think it came with my ST Kickstarter kit way back when. I tried all of the usual things, including air gap switch and breaker. Both of my old ones failed.

That’s horrible. I think it’s time to switch brands of switches!

I read somewhere long ago that any sort of power in line or similar network over home electrical lines (like some home energy monitors that plug into your circuit breaker) can cause these GE switches to fail. Just an fyi.

One of my GE Z-Wave switches seems to have dropped off my hub. It wouldn’t respond to any command and showed as “inactive” in the web interface. Not sure what happened.

I tried popping the little switch out and sticking it back in, but that didn’t help. I then tried just adding it as a new device, and the hub instantly discovered it as a new switch. I’m not sure if resetting the little switch made that happen or else somehow it was already disassociated from the hub.

Either way, my problem now is that I’ve got SmartApps attached to the old/inactive instance of the switch, and it would be nice if I could somehow “transfer” the ID or whatever of the new working one to the old instance without having to remove/re-add it do all the apps.

Has anyone had any luck with anything like this?

Next time it happends you may want to take a different approach to adding it back.


Thanks, I’ll try that next time.

This is a known problem with GE switches, you will find much discussion in the forums. (And on other sites-- it has to do with the GE switch, not SmartThings.)

Many times you can get it to reconnect on its own by throwing the power at the breaker (not just the switch). So that’s worth a try if it happens again.

Thanks. I had read similar threads in the past but couldn’t remember where I saw them. I assumed sliding the little plastic piece out was the same effect as flipping the breaker because it seemingly kills power to the switch, so when that didn’t work I wasn’t sure what was going on. I did not expect ST to rediscover the switch the way it did, which is what really threw me, and my main question here was mainly centered more on seeing if there was some secret way via the web interface to move things around without manually redoing SmartApp stuff.

Right, for that the “replace” utility that was already mentioned works well. :sunglasses: I believe this feature was only added in 2015, so earlier threads won’t mention it.

As far as the switch, unfortunately just pulling the airgap on the switch itself doesn’t seem to solve the problem. You have to cut full power to the circuit. There are some technical reasons why those two activities may produce a different result, but I don’t know if they actually apply here. It’s just something that people have reported as working when the airgap doesn’t.

This is one of my pet peeves with home automation and SmartThings in particular. This has been a known issue that frustrates users, regardless if it is GE’s fault (I’m not convinced). Now that they know the issue, sold these switches and thousands suffer from this, there seems no motivation to resolve it. Instead they rely on support handling this on a one on one basis.

They should be able to write defensive code and utilities that handle the issue after the fact, in my opinion.

Home automation hubs must be able to handle uncooperative devices. These GE switches won’t be the last. Otherwise home automation will continue to be only the domain of the hobbyist and never reach the mainstream status.

Stepping off soapbox…


Pretty sure it is GE’s fault, just because you’ll find the same complaints on Vera and Homeseer boards. So 3 different zwave controllers, same switch drop offs (always the same brand), sounds like the switch. :wink:

However, since this is the only switch brand that SmartThings has chosen to carry in their own webstore, I certainly agree it would make sense if they had a better way of handling the issue.

If I ran the company, I wouldn’t allow engineers to use this as an excuse. And if they could prove it to me I would have them minimize the issue and distinguish SmartThings as better than the others.

Customers don’t care who’s fault it is, they want solutions. This is reality, and the first home automation company that realizes this and addresses it will win. SmartThings management relies on their support staff too much to fix things, in my opinion.

Again, stepping off my soapbox…

1 Like

The good news is, this is a very rare occurrence for me, so it’s really not a big deal. ST does have a tool to make things easy enough to bring things back into line, so that works for me.

Granted, this is the kind of thing that prevents ST from moving more mainstream as you say, but there are other things I wish they’d fix before this.

1 Like


Glad you’re back up and running without much of a hiccup. You can always find a helpful SmartThings community to lend a hand.

So I’m finally fed up with these things and I’m about to rip them all out and probably dump light automation all together.

About every few weeks one of them will simply stop responding to commands. The only way to fix it is to re-pair it…which is a pain. Worse, my locks then stop working because it relies on the mesh network to make it to the hub.

Here is a screenshot showing what a repair looks like.

I have over 30 of these switches. And only 1 has ever given me a problem. I suggest that you exclude them and re-join them to your hub before making any big decisions.

You should also think about wireless interference near those switches.


As mentioned, the only way to get them to work again is to exclude and rejoin. I have done it dozens of times. They have also been doing it for over 2 years in two different houses.

How many switches?