Ge smartswitch zwave 12722 doesn't pair


(Jeremy Gray) #1

I’ve just installed the 12722 just 5 feet from hub. When i put hub in pairing mode and click the switch, it does not show up on the hub for pairing. I have one other ZWave device which is nearby and it does pair. Is there a device handler i need to copy and publish to my hub?


#2

You should not need to copy a device handler for that switch. Most of mine GE 12722’s and 12724’s would take 30-60 to pair up with the hub. I just keep turning the switch on an off 4-6 times while in pairing mode. If that doesn’t work, you can also try to do a General Device Exclusion first. Then try and pair it again after that.


(Jeremy Gray) #3

Hi NMK95! Thanks for your response: a follow-up question to your reply: you say “30-60 to pair with the hub”, is this in seconds or minutes? Thanks…


#4

Sorry about that, 30-60 seconds.


(Nate) #5

I’ve also had luck with pressing and holding the switch in either the on or off position. Not sure if this actually helped, but I’ve tried just pushing the button and nothing ever happened. When I held it down, it then paired.


(Ron Talley) #6

The proper procedure is to:
While Hub is searching for new devices, Turn On the Switch then Turn Off the switch. Wait until it shows up as new device. Can take up to 1 minute.

It might already be paired…

Try excluding it by going to home menu, Hub, zwave utilities, then exclude. Same procedure as above.


(Mark) #7

Agree w/ @rontalley. Sometimes even brand new z-wave devices need to be excluded before they can be paired; I believe they get paired to a z-wave controller at the factory for QA purposes.