GE Link Randomly stops accepting commands


(Jason Hamilton) #1

Hey Everyone,

So I emailed support because I thought the GE Link bulbs were “Officially Supported”. Apparently they’re not. I couldn’t find a similar thread for what I’m experiencing.

I’ve had to do this twice now in the last two weeks where some of the 5 bulbs I have just either don’t turn on, or they turn on with the smart app and then won’t turn off. The only way I can fix it is to cut the power to the device (switch/unscrew) and then turn the power back on. This wouldn’t be such a pain if I didn’t have to climb on a ladder for my driveway lights. I haven’t been able to determine exactly what is causing this and was wondering if anyone else has experienced this and maybe you found a solution. Do you think rebuilding my routing tables might fix it?

Thank you all for your help.


GE light bulb would blink as if it has been paired but would not appear on app (Help)
(Greg) #2

This happens to me with only one bulb out of my 4 GE Links. Someone in another thread said they feel this is related to heat because I have it in an enclosure, which isn’t recommended. I think that is possible, but there are two bulbs in the enclosure and it is only the one that has an issue.

It happens to me maybe every other week. I turn the bulb off via the switch for a few min, then turn back on and all is fine again. I’ve been meaning to swap the trouble bulb out of that fixture to see if it still has issues when not in an enclosure, but just haven’t gotten around to it.


(Jason Hamilton) #3

Yeah 3 of mine are in enclosures outside but they’re well ventalated. The other 2 are in lamps here in the house. These are your standard floor lamps where the bulb sits on the top with the shade below it like a bowl. So I’m not sure if the heat could be related there.


(Jason Hamilton) #4

So I installed the pollster and had it set to every 5min but still no love here. So I just lowered it down to every 2min to see if I have any better luck with the lights dropping their communications with the hub.


(John Shepherd) #5

I have similar problems with 2 link bulbs in my dining area. They seem to always disconnect. I can flick them on/off from ST, but they don’t respond at all.

To make matters worse, getting them back and re-connected feels like a complete crap shoot. I cycle them off/on every 2 seconds and nothing happens.

Would love to hear any other troubleshooting I could do.


(Alex Christensen) #6

I had a Link bulb in a post lamp in my back yard for several months. It would occasionally miss commands but on average worked well. Then the house next door got sold. Almost immediately after the new neighbors moved in it stopped working at all reliably. I replaced it with a z-wave bulb which works perfectly. I’m suspecting the neighbors Wi-Fi and/or additional 2.4GHz devices were enough to kill the marginal connection. That bulb has been inside the house since then and continues to work perfectly while closer to the rest of my network.