GE Launches Seriously Cheap Wink Connected Bulb

Hmmmm, getting this error after pairing the 2nd bulb:

groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.math.BigInteger#. Cannot resolve which method to invoke for [null, class java.lang.Integer] due to overlapping prototypes between: [class [I, int] [class [B, int] [class java.lang.String, int] @ line 177

I had this same thing with my control4 dimmer. Seems something to do getting the endpointId

Anyone with any thoughts?

Anyone notice the packaging? For help go to and that doesn’t even have a site on it?

Zero docs in the box, no idea how to unpair and repair?

Based on @cmonroe initial code, I fixed the fingerprint so they pair to this devicetype…

Also put in a git repo so the world can access.

FYI, unpairing is simple, just delete from app or IDE and power cycle the bulb and re-pair.

1 Like

I love these cheap zigbee bulbs… A couple of “flaws” but no idea how to get around them…

If the bulbs lose power then regain power, they automatically turn on, so they have no knowledge of their last state, they turn on to 100%

There doesn’t seem to be any type of broadcast on power up to intercept either. Other then this:

2:48:01 PM:
cp desc: ps_GE Link Bulb updated

2:48:01 PM:
cp desc: desc: 01 0104 0101 02 07 0000 0003 0004 0005 0006 0008 1000 01 0019

But this was traced in my sonos connect app? WTF?

So it appears on power up these bulbs issue a join but the hub doesn’t know what to do with it.

I think there needs to be some sort of refresh or poll to get their status so when you open things, they show the right status… For whatever reason that is out of sync.

Mine seemed to pair and map to the driver just fine with the fingerprint in my original post. It looks like the only change you made was the addition of the endpointId set to 1 which from my understanding was the default so no need to set; also no need to expose the getClusters command.

Regarding power on after power failure this is somewhat an annoyance and somewhat a feature. All Philips Hue bulbs behave the exact same way. It’s nice in some ways because you can flip a switch at night and have the lights come on, but sucks to come home after a power outage with all lights on.

There is a working refresh method in the original code I posted, I think we just need to update the device driver to store the last state and poll on an interval (5, 10, whatever minutes). As long as you are OK with the hub being the “master” it can easily then poll for state and on detection of state change (e.g. on when it really should be off) it’d be very simple to send the off command when an event like this occurs which I think would be ideal. I never investigated this with Hue but assume it could be easily done in the Hue integration layer as well. Maybe add a check box in the config/preferences for each bulb that specifies what to do when a state mismatch is detected; I assume some prefer the existing behavior while others would prefer their ST hub detect lights turned on due to power loss and turn them off.


I’ve tweaked it a bit more then that… That first publish was mostly just your code from the Hue Zigbee version…

As for the poll, I got the refresh to get the current set dimmer value from endpoint 08 and parse it (not effectively) and set it…

Anyway, feel free to use whatever you want, I just don’t like having code posted in these forums as with the last version of the forums, things disappear. If you want to start your own github, I’d be more than happy to merge mine and commit to yours.

As for the fingerprint, it was needed to force the pairing to use this devicetype. Without it, all other bulbs just showed up as “Things”…

I still think there is something that should be bound to using the bind zigbee command to get these bulbs to check in every so often with their status. This would solve alot of the issues and wouldn’t need to constantly poll the device.

I just modded the power outage app to turn them off after power is restored after an outage. This allows me to leave a couple on if mode is night.

So for those of you that snagged a shiny new Wink hub (man this thing’s a beast) for 99¢, have you set it up? Is there anything interesting about it to be found?


After some time on the phone was directed to another Home Depot. Every store in my area seems clueless. I drove the extra distance and snagged five of the six bulbs. The guy on the floor was excited to know if it worked with the Wink hub.

It seems if you are on the 000.011.00603 firmware you can’t use either Chad or Patrick’s device type. I can only use the bulb if I leave it as a smart power outlet. I’ve requested the update from support, but with it being a holiday weekend I may have to wait until Tuesday I suspect.

I haven’t opened my wink hub yet, not sure if I even will. But for $1 I figured why not.

Interesting… Wonder if that is why my other zigbee device started working when I was on the new firmware… Hmmmmm…

Why do you have to request an update to the hub, why not automatic?

Crawls out from under my Lurk Rock

I am still on the 000.011.00603 firmware waiting for support to push an update (never before have I cursed a 3 day weekend…)

I’ve set up three of my five GE bulbs using the SmartPower Outlet profile. They all paired fine, direct to the ST hub a room away.

With my current firmware (000.011.00603) I am experiencing strange behavior when using the lights in the “Lights & Switches” section. I can turn a group of bulbs on and off but upon turning them off the app hangs on “Turning Off” even after the bulbs go out, then upon refresh (or killing the iOS app and restarting) it shows the bulbs as on even though they are off. Maddening.

Everything seemingly works fine from the “Things” menu when individually switching on and off the bulbs. Very snappy response.

I’m hoping my forthcoming firmware update fixes all this. People using 000.011.00705: does everything run smoothly, especially with team Chad/Padrick’s device type?

This $15 bulb is gonna be big…

I have one issue so far, its that the Thing doesn’t show the current bulb state, don’t know why, cause my other zigbee stuff does…

I may start over with a clean driver and see what’s missing…

@beckwith it seems that Home Depot roll out the program without updated the training for the managers or store employees.

@llcanada Agreed. When purchasing with the HomeDepot tear off coupon from the end cap the cashier seemed seriously confused - staring at the coupon then the bulb and hub packaging for 2-3 minutes before shrugging it off saying “Yeah, I’ve never seen this thing before…”

Patrick - so I know how to create a device type with this…

but then what happens…Sorry - Just a n00b!

I completely rewrote the devicetype. This seems to be working a lot better for me…

Might even work for those on the current firmware?

Anyone want to test?


The dimmer works better. No issues other than it seems to think there are two pages when I swipe right to left.

I’m using the new firmware.

Not sure what u mean two pages