GE \ JASCO on\off switch won't join

I recently put power to my shed and put two GE zwave on/off switches (non plus models) in a two gang box. One switch I connected to the load and it works great, the other I just attached hot, common and ground so that when I run my next set of lights I don’t have to undo all the wires in the box (have a place to properly tie in ground and common).

The problem I have now is that spare switch won’t join my network. The blue light turns on, I hear the relay going on/off when I manually push the button, it seems to respond to exclusion mode on the hub but I can’t add it.

I thought distance might be an issue but I have 4 door sensors, two zwave+ outlets (innovelli), a GE non-plus outlet, the other switch in the box and another GE switch in the same shed all working fine.

Does anyone know if I have to have a load attached in order for it to pair? I knew the old dimmers would have required it but the on/off seems like it should join since it powers up and seems to respond manually. Hoping I don’t have a bad switch.

I’ve never heard of a switch or dimmer requiring a load in order for it to be able to join. I have run into exclusion / inclusion issues many times before and if we exclude ST platform occasional issues, I would focus on distance, excluding the device, and above all performing a reset of the device. I typically exclude the device and then reset it. I repeat this process with every failed attempt to include the device. Also, my issues seem to have grown the more devices I have added. Distance is also a factor but if you have many other devices working then it likely is not that. Either way, I would have stuck with zwave plus for any new devices especially when there likely is more distance between nodes than there would be inside your home.

Try to reboot the hub (this has made inclusions easier for me for some reason), then exclude the device, and reset it. Then try to include it again. Hope it helps!


Thanks I’ll give those suggestions a try. I would have plus ones but I had these on hand from a deal I got on eBay a few years ago where they were super cheap. If I can’t get it to work quickly I’ll cut my losses and pick up a plus switch. It would be good for network strength for when I eventually remove the outlets.

Rebooted the hub and it picked right up just like it should have! Thanks

1 Like

I really should have tried that earlier but didn’t think it was a factor since I added my first new one, then tried the one I couldn’t get to work, then my third went in without issue. I had the power off to all until I was ready to pair them.

It could just be a coincidence and the rebooting had nothing to do with it but when I was rebuilding my system after migrating to v3, the reboots did seem to help. I got the impression the reboot put everything on hold for enough time for the hub to find my device before going back to whatever it was doing… just a wild guess.