GE 14291 LED indicator

You can always change it directly on the switch. Three fast presses of on and a single off will change the indicator light.

Happen to have the pattern of presses? The only one I can find completely disables the led

I believe they also changed the LED brightness at some point. I have a couple of old GE 12722 (non z wave) and new 46201 2nd gen (z wave plus) devices. The difference in indicator brightness is quite noticable.

Yes, included above

up,up,up,down (on,on,on,off) just completely disabled the LED on this switch.

I do have a fan controller that this procedure reverses the LED behavior.
I also just got an email back from Jasco that the only way to change it on this model is via the hub. The enable/disable led pattern above is the only thing you can change from the switch itself.

I know the setting used to be there in the device handler at one point.

Make sure switch is off. Repeat it again to toggle through options. I have many of these switches and it works on mine.

It definitely doesn’t work on this one I’ve got anyway.

It seems like the GE 14291 part number actually covers two parts (or generations perhaps).
Both are Zwave Plus switches, but the stamp on the face of the switch is either ZW4005 or ZW4008. Mine is the ZW4005 piece. I think the ZW4008 is just a newer version with slimmer housing, and supports S2 security.

ZW4005
https://products.z-wavealliance.org/products/2501?selectedFrequencyId=2

ZW4008
https://products.z-wavealliance.org/products/3317?selectedFrequencyId=2

You could switch to a device handler that allows you to configure the indicator, configure as desired, and then switch back.

Happen to know of one off hand?

I used to have the GE/Jasco ZWave Plus DTH by nuttytree, and I swear it used to have an option to configure the LED too but when I switched over to it the option isn’t there either.

Huh, you’re right, it absolutely was there, and shows that it should be there when I look at the DTH code, but it’s not. There’s a field in the settings that’s unlabeled and all of mine say “on” which based on the code corresponds to the correct setting of “When On”. I’ve tried changing the “on” to “off”, “never”, and “When Off” and it doesn’t seem to change anything. I can see the indicator light setting in the IDE but there’s no way to edit it there. Very strange…

Okay, they’ve changed something and I’m not loosing my mind! :smiley:

Yep. I was able to change the led indicator behavior by using the z-wave tweaker DTH. Interestingly enough after doing so the option to edit the behavior popped up in the IDE. It’s parameter 3 and it looks like 0 is for the indicator light to be on when the light is off, 1 to have the indicator light on when the light is on, and 2 to have the indicator light always off.

Edit: while the option to edit the parameter in the IDE showed up after using the z-wave tweaker to change it, any changes in the IDE don’t seem to get applied. It also looks like the unlabeled field on the settings page is actually a history of parameter configuration settings, which is why editing there didn’t do anything. After messing around with one of my switches there’s a whole bunch more unlabeled fields there, all with numbers corresponding to the parameter changes I made.

Thanks. I have the zwave tweaker installed but haven’t played with it in forever. I’ll give it a shot.

I’ve noticed some other wonky behavior in the ide, changing settings not actually changing anything.

So I think we might have both done the same thing…

I played with the tweaker and went back and boom, my indicator status is available to edit too. Going back and forth a few times I realized the switch was using the built in “Z-Wave Switch Generic” DTH. Changing it to “Z-Wave Switch” lets you edit the indicator status.

No idea how all my GE switches got changed to the “Generic” DTH

Regardless you got me in the right direction, and we both learned something lol

Have GE finally worked out that people want to completely disable the LED on the fan switch yet? They really need to release a firmware update to fix that and the light dimming behavior where it jumps immediately to the set level rather than fading up or down.

I’m not sure about the fan switch. On,on,on,off toggles the behavior. It’s so bright in the bedroom I’m constantly changing it when we turn the fan on at night.

Yeah there’s no way to use ‘never lit’ on any generation of the fan switch unfortunately. There is a Smart App around here somewhere that basically automatically switches the behavior for you to mimic ‘never lit’.

So if the fan switch is currently off, it’ll switch it to ‘when on’ and if you turn the fan on, it’ll switch it to ‘when off’, if that makes sense.

However, if you have switched to the SmartThings stock fan controller DTH you can’t use this as the setting is not exposed by the DTH. Bit of a bummer.

1 Like

Really? I can change the LED behaviour on my fan switches with the stock DTH?

Hmmm, for me I do not get the LED indicator option anymore since switching to the ST fan DTH (so it shows up properly in Connect). And a side effect is the device no longer shows up in the app I posted above as well.

Edit: Did you mean to ask if you can? Did you mean “can’t” vs “can?”