Frustrated by the state of things

@SBDOBRESCU your post was so deadpan I thought you were serious. I laugh now when I reread.

I had a routine fail to perk up my thermostats, but it’s really easy for me to fix. Keeps happening I’ll start to get cranky.


can they change the name to ClusterF@#k instead. Seems like ST can’t do anything right lately

I too had to re-read it as well. Poe’s Law was in full effect.

Poe’s law is an Internet adage which states that, without a clear indicator of the author’s intent, parodies of extreme views will be mistaken by some readers for sincere expressions of the parodied views.

Might want to add a :wink: next time @SBDOBRESCU


The problem is that sunrise/sunset is an exact moment thing and not a make sure this happens after this moment type of action. It should be a clock in the hub that sets a flag (In_DayTime) that then everything that looks for sunrise or sunset uses. if it happens to not notice the change for 3 minutes, oh look we are not in daytime anymore fire my event.

Why they dont do that in the core code I’ll ever understand. but for a SOLID MINUTE any event should be able to fire (and then note it fired so it does not constantly fire for a minute straight) so that we dont have to rely on microsecond accuracy.

1 Like

I am not really sure that is the issue for missing events …in fact. Pretty sure it isn’t… I gave a good night rule that can fire anytime things quiet down from 12 am to 4 am and it still is being missed regularly.

My events are missing set both ways, sunset or an exact time.

Hey Brian, I know this is too obvious, but I just had a routine that didn’t change my thermostats, so when I went in, I noticed that the thermostats got de-selected for some reason. I re-selected them and ran the routine manually and that fixed it for me…

My setup has been working great for a while (almost perfect)…

…until yesterday evening.

I had a device “fail”, so I did a replace through the app. It seemed to work OK. but since the device acted as a repeater for others I kicked off a Z-Wave repair. I’ve done this before and it has always solved my problem.

No errors encountered during the repair, but everything, and I mean everything has failed. The whole freakin’ thing went to shit real quick.

Now if I delete a device and re-add it, I can control it (albeit briefly). However the app always shows the incorrect device state. Also, when turning the device on or off, the event never shows in the log for the device. The problem seems to affect ALL Z-Wave devices. All Zigbee, LAN, and cloud devices work fine.

All automation fails 100% of the time. If a contact sensor (Zigbee) triggers an event, it shows in the log, but the device never responds. If I manually trigger a device, it sometimes works, most often it fails.

ST went from HERO to ZERO in a blink of the eye.

All of this happened yesterday evening. I do not have the update. I don’t know if it is related. I have contacted support. They ran a Z-Wave network repair (by the way, this disables the devices that I added back it - it is at this point that I loose them completely). It was suggested that I start over and rebuild everything (200 devices). I’m almost to that point. BUT, when I add a device that is located next to the hub, it too experiences all of the same problems (state out of sync, automations fail, network repair trashes control - even though that was barely working). I did turn the hub off for an hour - still no go. I have flipped breakers - same problems (rinse and repeat).

UPDATE - Zigbee now fails 100% too. Now only LAN and Cloud work (so my virtual switches are still thriving in this failed environment).

Any thoughts???

V1 or V2 hub?

If V2, I would guess there is a synch failure between local processing and the cloud. Perhaps the firmware update started and failed midway?

If V1, I would guess account processing failure in the cloud, as in it doesn’t know your location so it’s throwing away messages.

But those are just guesses of the “this is where I start looking first” type. No way to know for sure. Having support involved seems like the best idea.

I feel your pain, I know this is really frustrating. I hope they find a fix for you soon.

in a way, it’s good that the zigbee has started to fail too, because it makes it less likely that it’s just your Z wave antenna going out.

Have you looked to see what you have eligible to run locally?

It’s v2.

I wondered about a failed update too.

About 35 automatons run locally. Or at least they did. Nothing runs now - local or otherwise (other than burial switches attached to harmony). I’m starting to think the hub failed.

It sounds remarkably similar to my experience that started 3 weeks ago and seems that it ended with yesterday’s firmware update. What worked for me, was to reinstall device types from ide, for all of the failed devices. That would kill your local processing and stabilize your system. So if motion sensor fails, go in ide, save the device type under SmartSense Motion Sensor non-local and then change the device type. You’ll need to do that for any zigbee devices that fail. I didn’t have any problems with any of the z-wave devices.

1 Like

It would make sense, a firmware update was pushed out Friday night. Mine had a lot of problems completing. (This went on for five hours. It was not my internet connection, only ST had problems.)

Surely SmartThings built-in some sort of diagnostics to the Hub V2? There are at least 3 LEDs that can indicate health or lack thereof, and a phone-home or ping from the Cloud should be able to scan its local logs for a heartbeat … or lack thereof…


Sure, but a failed firmware update can brick any device.

Agreed… so what would the appropriate indication from the LEDs be in that situation?

Even a “bricked” Hub should have a BIOS that invokes a bare metal self-test prior to booting the variable firmware.
In the worst case … the LEDs would all be off or indicate “power only / unable to boot”.

There is a reason Hub V2 has 3 (THREE) LEDs.

I’m not sure “firmware” means what you think it means.

If you crash a firmware update, there’s nobody left to turn on the lights. Or turn them off if you crash midway. The device is brain dead.

1 Like

@bago I had a similar experience starting last night. I lost all ability to push any commands to any of my z-wave devices. The hub would get updates from the devices (ie I toggle a light switch at the wall, but I was unable to do anything from the app.

From my Vera days, I was leery of doing a z-wave network repair. Don’t know if that’s an issue on ST, but doing a repair when you had another problem would basically ensure you’d have to pair the devices again once you solved the real problem.

Anyway, I removed the batteries from the hub, and removed the power. Within a minute or two, I tried controlling devices again, and it failed. I went and sent off an email to support, and about 15 minutes later, I tried again. Lo and behold, everything’s working again. I’m not 100% sure that support didn’t do something behind the scenes, but I’d think it’s VERY unlikely :slight_smile:

If you haven’t already, you might try a hard power cycle and see if that helps.



All green. Looks like it works like a champ. Even a network repair goes smoothly. Unfortunately it’s not real. In reality, absolutely nothing works, and I mean nothing.

@bago Can you control anyrhing from your phone?

Nothing. I can’t even re-add a device.