Four button Tuya Zigbee device DTH (DTH link in post #7) (Same device from multiple brands: Zemismart, Yagusmart, Losonho , DYHF, etc)

@Trakker2 Thank you for your recommendation i have ordered a Smart+ Switch hope it will work from the start :slight_smile:

@daverda00 I am sorry that the switch that I recommended didn’t work out of the box… Hope you can find information and help in the ST forum and it will work for you.

I have removed the links from my previous post, sorry again.

BTW, I have made some more optimizations to TS004F driver operating in scene mode only. Now I can pair it even when the switch is away from my ST hub, i.e. the initialization is now much less dependant on delays or retransmission errors during the initialization. Revision 2.4 can be downloaded from the same link.

@Trakker2 Don’t worry about the new switches issues, I’m starting to understand that the zigbee world is a world full of luck and random issues :smiley:

I have tried your new version of the DTH, still no improvements. It pairs perfectly each time but no message gets sent on the live logging. Maybe I have some kind of updated version of the switch as your DTH works for the most of the people here.

Btw I have configured the switch to a tuya zigbee gateway, where it works perfectly. This means the switch is not faulty.
But nevermind I can still use the switch for tuya automations so it’s not completely useless.
Thanks again I really appreciate your help.

2 Likes

So I managed to solve the issue with the help of @Trakker2
I had to keep pressed the two buttons on the right row (2 dots and 4 dots) for about 5-6 seconds until the led of the 3-dot-button lights up for a split second.
This changes the “mode” of the button and from then on it worked perfectly. Single tap, double tap and hold are shown on the live logging and recognized from the app aswell.
@Trakker2 thank you again for the great help!

1 Like

I am glad this worked for you ! :slight_smile:

Last version 2.6 : - added ‘Reverse button order’ setting back (off by default)

* ---------                    ---------
 * ! 4 ! 3 !                    ! 1 ! 2 !
 * ---------                    ---------
 * ! 1 ! 2 !                    ! 3 ! 4 !
 * --------- : default          --------- : 'Reverse button order' setting ON 

Keymapping can be changed from the mobile app - click on the device details page 3 dots icon (upper right corner of the screen), then Settings, “Reverse button order”.

1 Like

@Trakker2
I have tested this DH a bit more, and I’ve noticed a problem with storing Actions on the device page on the Smarthings app.

When adding actions for each button (pressed, 2x, held), the actions do successfully get registered in Smartthings, and they appear on the Automations tab. (And they work!)

However - only the actions for button 1 show within the device controls. I can add an action to any other button, it stores correctly on the Automations tab, but on the device controls it says “No actions assigned”.

If I do add an action for another button, that action replaces the action assigned to button 1 in the device controls presentation - even though it doesn’t actually replace the Automation (which works successfully).

I hope this all makes sense.

Have you seen this before, and any guidance how it can be fixed?

Thanks

1 Like

I am not sure how to fix this, seems like something has changed in ST new mobile application, I don’t follow these changes very closely… Anyway, the solution should be the same as for any other 4 button devices, such as TS0044 for example.

Have you tried ‘Routines’ ? :
press the ‘+’ button on the mobile app, then ‘Add routine’, select ‘Custom’ at the bottom left, ‘If’ → ‘Device status’, select the TS004F device, select one of the 4 buttons, select one of Pressed / Double pressed / Held options for that button, hit Done, then assign a device to control …

Does this work for your setup?

@nayelyz this the same issue that I reported couple days ago with EcoSmart Remote. It is happening with other devices too. Those Fast Automations on main Device’s page are not working.

@Trakker2 this is something that happened on ST side, as device that I have, have exactly the same problem and is using SmartThings stock DTH.

See my post and response from @nayelyz

1 Like

Thanks @milandjurovic71 - it does appear to be exactly the same problem.
The only reason I can’t be 100% sure is that I hadn’t properly tested the DTH prior to this, so don’t know if the recent change in Smartthings has caused this.

I’ll keep an eye on the other thread to see if there’s any updates for you.

My previous feedback was related to _TZ3000_czuyt8lz which, apart from the issue mentioned above about actions not sticking to the buttons on the device page, the DTH seems to be working very well. (And I understand that this issue is down to Smartthings, and not the DTH).

I am now testing with _TZ3000_xabckq1v and I am getting very little success.
Button 4 (TL) seems to work, but nothing else.

I have tried switching to scene mode as per @daverda00 comment above in post 92.I can see in the logs that it supposedly switches modes, but I’m still not getting any other success with other buttons.

Is there anything else I can try, or any further updates to this DTH?

Thanks in advance

There seems to be a large variety of different devices by different manufacturers that use one and the same product identifier (model) TS004F…
@Hendo25 can you post a link to a picture of _TZ3000_czuyt8lz device?

_TZ3000_xabckq1v should be the same device that I am testing with. Looks like this:
image

Hi - yes that is the same as the _TZ3000_xabckq1v I am testing with, and which I am having difficulties getting to work properly.

(Pic of other device to follow later)

@trakker2 Thanks for all your hard work on this DTH.

I have a MOES 4-panel wireless switch, seems to be the Tuya that’s in this thread, picking up the _TZ3000_xabckq1v / TS004F identity.

I paired it, changed the device to use the DTH, and used the 2/4 button reset to get it to scene mode. Using the 2.6 version of the handler, only button 1 shows up in Live Logging. The other buttons do not respond.

Thoughts?

Hi @ssbn ,

Just changing the DHT is not enough to successfully initialize TS004F wireless switch into a scene control mode. After switching to this DHT, you need to re-pair the device.again , because it can be initialized into scene control mode only during the short time period (7-8 seconds) while it joins the zigbee network. The most effective way is to first delete it (from ST mobile app : device details page → Edit → Remove device ). At the time when you delete it, press button 1 to make sure the device wakes up and leaves the zigbee network. I recommend also removing the battery for about 1-2 minutes to make sure it loads factory defaults settings.

Then from the mobile app add new device ( “+”, “scan nearby” ). Put TS004F into pairing mode by holding the left bottom button for 6-7 seconds. Perform the pairing close to the ST hub, this reduces the possibilities for communication errors and packets retransmissions, respectively increasing the chances to successfully complete the initialization process. An indication of successful pairing is when all 4 LEDs stop flickering in about 4-5 seconds after the pairing process was started.

I have just updated the driver to version 3.0. It adds support for the new YSR-MINI-Z remote controls and also supports the default ‘Dimmer mode’ From the Groovy IDE device details page you can check what is the currently operational mode (“Scene” or “Dimmer” ).

I hope that I have also optimized the pairing timings a bit more in the new version 3.0. Please update the DHT and let me know if it works for you.

All buttons now register all actions however i cannot assign actions to buttons 3,4 and 5.

1 Like

Have you tried the ABC - Advanced Button Controller - Newest Edition ?

I’m new to that - how can that help?

The Advanced Button Controller was one of the few custom applications that in the last weeks were able to make use of the multiple buttons controllers… until yesterday!

Samsung have finally managed to fix the long-lasting bug in SmartThings mobile app, and now it is possible to assign different simple actions (routines) from the mobile app device page:

Check Google or Apple stores on your mobile device to make sure you have the mobile app updated to the latest version.

1 Like

Ive finally managed to setup in smartthings with a device handler 1.6 but press any button & nothing happends , if i add a routing to Button 1 nothing happens, if i setup a routine in any other button they dont even show up? Hope someone can help

Can you post the device details as shown in the Groovy IDE, ‘My devices’ tab?
Should be something like this: