Four button Tuya Zigbee device DTH (DTH link in post #7) (Same device from multiple brands: Zemismart, Yagusmart, Losonho , DYHF, etc)

Version 1.6 worked for me!
I tried it before and it definitely didn’t do anything.
Tried it again and it just started working.
The buttons aren’t always 100% responsive (altho this may be a wireless connectivity issue as my devices are far apart).
Brilliant!

2 Likes

Hi @DavidFrat123

I have the exact same issues as you have. I’m running Hub v2, new app, and bought the TS004F version.

I tried the v1.6 of the DTH from the 7th post in this thread, but unfortunately it doesnt work still. Can I trouble you to post the code that worked for you, please?

https://www.zemismart.com/pages/zigbee-handler-download-38

3 Likes

The Zemismart DH works well with my Moes 4 scene Remote control thanks!

2 Likes

Hello, I am using dth v 1.6 and wirks well in smartthings app.
Only thing it seems I can’t do it is to assigne double click in webcore.
In the list of devices I have 1 generic button + button 1,2,3,4.
I thought double click (e.g. for button 1) was generic button, select button and set 5, but it doesn’t work.
Do you know how to do it?
Thank you very much.

I buy a Moes 4 Scene too… and use the Zemismart DH from here:
https://www.zemismart.com/pages/zigbee-handler-download-38
Is the same that you use?

I have this one

And used the 4 gang Zemismart DH

Thanks for help… its a different model =(

Hi everyone,
i just used the 1.6 V of the zemismart 4 gang DH and everything works fine. one issue that i have is that button 1 and 3 control my xiaomi smart plugs without reason… any solution for this?

Thank you!!!

Hey @omrialc I have the same problem, did u solve it ?

How did you get it to work? I have the same switch and DTH 1.6 and it does not show any activity when I press the buttons… But, the device is added to Smartthings when I reset it. Thanks

1 Like

Hi David, this is not working on the TS004F for me. It detects as Tuya button but does nothing when I press the buttons also.

1 Like

Did you get yours to work? I seem to have the same model as you but cant get it to work, it shows up as:

  • manufacturer: _TZ3000_xabckq1v
  • model: TS004F

I tried to use the 1.6 DH code but it does not seem to do anything

I can only get them working with ZHA using homeassistant. Seems the zigbee2mqtt developers are struggling to make a device handler for this particular model too.

Shame, I could do with finding something that works with smartthings easily so I can buy a few 1/2/3/4 button versions

Is there anything that is zigbee and ‘just works’

I am kindly looking for a DTH for my Tuya 4 gang sold by Si Smart … all those tried so far do not work despite the device being found by the HUB ST

Thank you

hi, you have found the right DTH

If someone has some free time and TS004F in hands to test with, can you try a new experimental version here : link

In my environment, the switching to Scene mode and the processing of pushed, double, and held keypress events are working OK.

@Trakker2 Thanks for this.
I’ve tested your version today, and after switching mode, it worked well - I had single/double press, and hold working on all 4 buttons.

However - could you please explain the different modes? When first connected I could only get limited functionality (hold did not work on 2 buttons).

But I don’t see any change in the appearance in the app by changing modes. I’m not sure whether I’m using Dimmer or Scene mode, and I don’t think I can switch back. I got the blink on LED 1 when I switched for the 1st time, but it doesn’t blink when I try to change back.

Thanks in advance