Forgetful z-wave - will 19.22 address?


(Steve S) #1

I noticed in the release notes that two of the items listed are:

  • Bug fixes and performance improvements for Z-Wave.
  • Bug fixes for potential connection issues in large Z-Wave networks.

Ever since I’ve been using SmartThings (Oct 2013), every other month or so, a random z-wave switch (Jasco/GE) will drop off the network. That is, I get the little red “!” (I have device health turned on) and I have to “replace” the device in order to get it functioning again.

Is there functionality in this firmware to address this? Or are these two things more like generic “the z-wave code changed” indicators?


(Kianoosh Karami) #2

Hi Steve,

There have been multiple Z-Wave related bug fixes since the 18.22 release that fixed reported by users or found during QA process. Unfortunately, the genericness aspect of the release notes is not by choice. To really explain what we have solved, one must know more information about the inner works of the firmware and z-wave and even then, it is not guaranteed that the changes will fix the issue given that the issue may or not may exist on a hub and Z-Wave Network. Therefore, I opted to go with the genericness instead of confusing users or providing too technical of information that a user may or may not grasp something useful. I would like to provide users with more definite and specific release notes, hopefully in the future release :).

Also, I am sorry that you are experiencing random drop off issue. If you would like to, let me know when the issue occurs and I can certainly take a look and spend some time to find a fix or understand the root cause of the issue.

Kianoosh


(Steve S) #3

Thanks for the reply - I know why they are generic :slight_smile: I was just hoping that one the fixes was addressing the dropping of the switches. It’s been around forever, so it was wishful thinking on my part.

I’d be happy to provide whatever you need, but if you find a fix, you will have solved a problem that’s been around for 4 years.

I have two switches I had to “replace” on Friday to get them back. The problem is these are in rarely used locations in my house, so I don’t remember the last time I would have used ST to command them. All I know is I opened the app and happened to notice the red “!” that indicated it was not responding. Looking at the device events in the IDE they only go back ~1 week.