Forced migration to new app

I’m beginning to understand the email issue warnings we get now. Only had a couple connection problems with the classic app (usually only just after a firmware update). Didn’t really correlate to the emails we got.
I notice a problem before every email we get now that I’m forced to use the new app…

Ever since being forced to migrate to the new app, I’ve had nothing but trouble with automations/smartapps that had run perfectly fine with the same hardware/settings on the classic app.

Now there is no way back.

I used to have an automation that would unlock the front door, and turn on the driveway light when either of our phones entered the geofence (100m radius?) after being away for 30min (the 30min would be long enough for the mobile presence to update to the correct location if, for whatever reason, mobile location was out of whack. To prevent unwanted triggering of the automation).
It worked perfectly, the geofence was large enough that the driveway light was on before either of us tried to pull into the driveway. The door never unlocked when the GPS went wonky for a couple minutes and the signal had to be re-acquired.

Then we got forced to migrate to the new app.

I had to delete the automation and set the geofence to a different timezone, before setting it back, to try to get it to function as before. I was told the geofence had to be 1km(??), which was way to large. The automation was triggering when either of the phones left the geofence, when it had been set to “either of our phones; at home; after being away for 30min”.

Got in touch with support, and have been going around in circles because there is no change in our hardware (phones are set to give location to new app, new app has all the permissions and is set with no background restrictions, and no battery optimization), and the app is the only thing that has changed. It is now in investigation. Why was this not checked before releasing the new app, never mind before forcing migration from the classic…

The mobile phones aren’t even a device, so we had to reinstall the classic app to see if the hub was registering when we left or came back (-it was. No change there. Geofence and mobile presence were working just fine).

Before the last update of the new app, the smartapps didn’t even function. I had to cobble together automations to get the aircon activate off of a different sensor at night to get a specific temp range, and another to bump the temp back up when it got too cold. Looks like the smartapps are fixed now, though.

tldr: new SmartThings app is not ready. Should not be forcing customers to migrate from the Classic SmartThings app.