Fixed: Tiles labeled "Tiles Missing", null device. Now able to delete


(Fernando Fuentes) #1

I have two tiles displaying “Tiles Missing” I can’t remove it and forcing it through ide gives an error of unable to remove null device.

Please help.


(Fernando Fuentes) #2

I was able to do an update to the device and than deleted it and that worked. Odd behavior.


(Gryffyn) #3

Mind giving more detail on how you updated the device? Mine seems to be from trying to pair a non-standard device before putting the custom device handler code in place. It shows up as “Thing” sometimes, but in the app it just says “Tiles Missing”. No device shows up in the IDE to try to delete. Device works fine on my home system (with device handler properly in place before pairing) but not at the office I initially screwed up the pairing of.

Thanks in advance for any details you can provide!


(Fernando Fuentes) #4

Interesting, I had a device in IDE and all I did was click edit and di not change anything I just hit update and was able to force a delete.


(Gryffyn) #5

Thanks… appreciate the info.


(Gryffyn) #6

Will update more later in case it’s useful to anyone else, but just noticed in the IDE that there are no hubs listed… even though a hub shows up in the app. Wonder if there’s a difference between having a Samsung account (new system for this business I’m working with) or having a classic ST account (what I have at home). Doubt that’d keep a hub from showing up while logged in (Samsung account). Going to see if re-setting up the hub works next time I’m over there… Thursday probably.


(Gryffyn) #7

I guess it sort of worked itself out… the hub still doesn’t appear in the IDE but the “thing” showed up eventually (took a while… like hours or a day or so) and I was able ot manually set it to the correct device type. Not sure why the hub isn’t showing up but everything seems ok I guess.

I might reset the hub and do the full setup again before I have more than one device on the system. Don’t want to add a bunch them figure out something’s not working and everything needs to be re-setup.


#8

Non developer here. Is the only way to delete the “Tiles missing” entries via an IDE? I have three showing up in my hub from some pairings that never worked and I can’t delete them or retry to connect to those devices. BTW, they were not Samsung devices but devices that are known to work with the Samsung hub.


(Oscar Hernandez) #9

That hapen to me when i turn on a new phillips light and try to add it directly in the smartthing app instead phillips hue. When i try to do something to it just keep telling error retry…


(Mike) #10

Hi Oscar,
I was able to remove Tiles MIssing by going into https://account.smartthings.com and then look for " my devices" and from there I was able to look for the “unknown” device that corresponded to each tiles missing.
Hope it work, good luck.


(Nmiiot) #11

I was able to correct this by manually selecting sensor type. When I let SmartThings “auto install” the Sylvania Lightify motion / thermometer sensor, it found it, installed it, but left Type “Unknown”. I went in and manually changed to “Samsung Smart Motion” and all worked as expected.