First Generation Kwikset Obsidian ZWAVE_S0_FAILED

Anyone having issues with device inclusion for their Obsidian Z-Wave locks? I have 4 of them and can’t get any to include properly. They all join with ZWAVE_S0_FAILED.
I’ve tried just about everything! Excluding, factory reset, hub reset, moving the lock right next to the hub when pairing. Fail and replace with Z-Wave PC Controller. Doesn’t matter what I do S0 security always fails. I’ve probably tried to include them about 30 times at this point!
The z-wave logs I’ve been able to trace don’t really help point to any specific problems. Just a generic node failed to join securely message. They do seem to take a very long time going through the inclusion process. Sometimes it’s been 5-8 minutes before I see the failed join after starting the inclusion process.
All the locks were working fine on Groovy so I assume something changed with the move to Edge or with a hub firmware update? I first paired them about 5 years ago and they’d been working fine but recently a couple went offline and I noticed only 2 of the 4 had been updated to edge so here I am trying to exclude/include.
The locks show model number 450242 written on them.

Kwikset support basically said, sorry not our problem. SmartThings support hasn’t gotten back to me. If anyone from ST sees this and can help out the ticket number is 1494391.

Fingers crossed someone out there has a solution! Really don’t want to replace all my exterior door locks!

  • install @philh30 Z-wave Lock PH Edge Driver —> Channel Invite
  • exclude the locks
  • bring the hub within inches of the locks
  • Add Device > by device type > z-wave

Gave it a try with that driver. It did use that driver when it included but still get the same S0 failure. :frowning_face:

Screenshot 2023-06-04 at 4.32.10 PM