SmartThings Community

Fire Tablet Setup Script for ActionTiles [BETA UPDATE 12-4-18]

dashboardhardware
actiontiles
fireos

(dhsemp) #124

Well considering the frame and cable is only $30 bucks, i’d consider getting it even if you only need the cable.

Before finding this mount/cable, I bought two other flat mount cables for $15-20 each, but they still protruded way too far out from the Kindle and were of crappy quality.

The one that comes with this kit is truly flat, high-quality, and works great. He will not sell the cable separately, I already asked. It’s what differentiates himself from his competition and I frankly don’t blame him.


#125

I was able to run the revised script although it still did not remove the Ads. Any other ideas?

Thanks,
Victor


(Mark) #126

Hey @aron7676, thanks for the setup script! I just got 3 Amazon Fire OS 5.4.0.1. Your utility generally worked very well. I saw three issues that I thought you’d appreciate knowing about:

  • Step 2 errored out. I assume this is because I bought the Fires “without special offers” (Amazon speak for “doesn’t include ads on lock screen”, which you get to pay ~$20 for the privilege of not having the ads). If I had not paid the $20, wonder if your utility would have done the trick?

  • I couldn’t tell if Step 1 (blocking updates and removing Amazon OTA) actually worked. Is there a way for me to verify this?

  • Lots of errors on Step 3 (and not just the error messages that were noted as acceptable). Is there a way for me to know which apps I don’t need (or, if easier, which apps I do need) on the Fire if all I’m using it for is as a ActionTiles/Fully browser for ST? I assume I can somehow delete the bloatware manually (I’m a Fire noob).

Let me know your thoughts. And, again, thanks for the awesome utility!


(Adam Davidson) #127

I’m having a problem with Step 6 on this… After installing the Launcher Hijacker, it asks me to select Nova Launcher, and press OK.

I do that, but there’s no feedback on the device, or the script, so I just press okay and continue.

After, there doesn’t seem to be any Launcher configured on the Fire, so I just have an empty screen with only Google and Chrome on the menu. I’ve no access to any of the apps, because there are no other icons on the screen

EDIT: I managed to get back into the HiJacker, and swap the Launcher back to the Fire Launcher… I can see the apps on the home screen, which lets me then configure LANNouncer, but when I tried to open Nova Launcher, it just flashes black once and does nothing


(Clint) #128

Nevermind… Didn’t have ADB enabled properly


(Glenn Smith) #129

I received a device with the right software to use the script and it has all worked. I’ve just unlocked it and I was forced to set a pin as there are kids profiles on my amazon account. To stop it being used it says I need to hide them or similar, but the settings for this doesn’t work, i assume as the software needed has been removed by the scripts. Any ideas on ways around this?

thanks,


#130

Once you’ve run the script, I would avoid even signing into an Amazon account. It’s just going to cause complications.

You’re best bet might be to factory reset and re-run the scripts.


(Glenn Smith) #131

I didn’t think I did; I had no choice to enter my password to get back in to the device. I wonder if they pre-registered it. I might try deregistering it first to see if this saves setup again.

Thanks


(Mike) #132

Taking this a step farther, ive installed automate-IT and smartthings since the play store is on it. on my non Fire OS devices, ST sends a notification that automateIT sees and opens an app or a webpage, or whatever. The problem, though, is the Fire tab doesnt get notifications from ST. ive made sure the notifications arent blocked and every other non fire OS device gets the push notifications, but none of my fire tabs do. is there any way to get notifications or any adjustment that can be made on the script that would allow notifications to come through? I feel like there is something in the OS blocking the notifications but i cant figure out what - its not the notification settings.


#133

I ran into the same issue. For what I wanted to do, I worked around it by configuring an IFTTT applet to send a notification and then have AutomateIT pick up the notification from IFTTT rather than SmartThings.


(Mike) #134

ok thats a good idea. little more work but if it does the trick its good enough for me. no issues getting IFTTT notifications with a fire tablets?


#135

It’s working for me. :slight_smile:


(Mike) #136

awesome. im going to test it today. Thanks for the idea!


(Jason) #137

I have the same problem, they used to work just fine and then one day they stopped and never came back. Pretty sure this happened after the tablet was updated to the most recent build. Not sure if it is an ST app issue or a fire tablet issue.


(Mike) #138

i dont get it. i cant get notifications from IFTTT or stringify in fire OS either. maybe a factory reset is next and ill start over.


(Adam Davidson) #139

Any tips how steps 1-3 can be done for a new Fire 7 tablet 5.6.0.0?

I saw that the stock apps would not be removable, but I seem to be unable to remove the OTA updates, and Lockscreen Ads :frowning:


(Aaron) #141

Did you extract the zip file? It won’t work unless you extract it.


(Jay) #142

Extracted, ran .bat file, selected e but can’t find device


(Jason) #143

Did you ever do a reset, interested to know if it fixed the issue. The only app I get notifications from on the fire tablet is the Ring doorbell app.


(Mike) #144

No, I haven’t had as much free time as I expected. With any luck I’ll get to mess with it this weekend.