Fingerprint removed from Stock Zigbee Vent driver?

I have several Keen Vents that automatically migrated from DTH to the stock Edge Zigbee Vent driver. They all worked. A few days ago one vent became unresponsive. I thought it was a battery issue, but that ended up not being the case. Ultimately I removed the device from ST, and re-paired it. However, I now noticed that ST assigned it with a Zigbee Dimmer Switch driver instead of the Vent Driver it had prior to the problems. I tried changing the driver in the ST app, but no alternatives are listed. So I went into the web app and tried changing the driver there to Zigbee Vent but get a fingerprint error. (See attached screenshot.) Does anyone know if it’s possible that the fingerprint was “dropped” from the Zigbee Vent Driver and that’s why it became unresponsive to begin with and that’s why it won’t install now? And if a fingerprint has been “dropped” from a stock driver, how do we get that corrected?

Tagging @nayelyz

1 Like

Hi, @TylerDurden
Can you share the fingerprint of the device, please?
It can be found in the Advanced Users app in the properties Model and Device Manufacturer.
Is the device that stopped working the same model as the others that don’t have issues?

1 Like

The Mfg Code is Keen Home Inc
The model is SV02-610-MP-1.3

Other vents that still works are:
Keen Home Inc
SV01-612-MP-1.0
SV01-610-MP-1.0

I have no other vents installed that are SV02-610-MP-1.3

Only these fingerprints are in the driver:

- id: "keen/sv01-610-mp-1.1"
    deviceLabel: Keen Home Vent
    manufacturer: Keen Home Inc
    model: SV01-610-MP-1.1
    deviceProfileName: vent-profile-1
  - id: "keen/sv01-412-mp-1.4"
    deviceLabel: Keen Home Vent
    manufacturer: Keen Home Inc
    model: SV01-412-MP-1.4
    deviceProfileName: vent-profile-1

ST needs to add them or you could ask @Mariano_Colmenarejo to add them to his driver. He has some Keen vents but not yours in the fingerprints currently.

From what I see in the repository, this fingerprint was never part of the Edge drivers, are you sure they got migrated to the “Zigbee Vent” driver specifically? It doesn’t have any generic fingerprint, so, it shouldn’t have been migrated to that driver.

Yes. And if you see @h0ckeysk8er’s post in this thread, it looks like my other vents that were migrated to the Edge Zigbee Vent driver have fingerprints that aren’t part of the driver as well. I’m not sure how the migration works, but I couldn’t possibly have switched these devices from dth over to Edge since the fingerprint match would be required for me. But I still have 5 vents with these “unregistered” fingerprints running successfully on the Edge Zigbee Vent Driver. I had 6 vents running on it until I removed the device and tried to add it again myself in the ST app. I assume that will happen to my other vents if I perform the same procedure. Let me know if you need any details about my account or devices. It would seem that something in the migration logic or process may have ignored the lack of a fingerprint match?

Please, provide support access to your account, I need to ask the engineering team about that:

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  2. Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

Also, please share the name of those devices.

1 Like

Thanks @nayelyz, my community account email is the same as my ST account. I have enabled data access. My Keen Vent devices are listed below:

Bathroom Vent
Bedroom Vent
Loft Vent (not able to use zigbee vent driver anymore)
Office Vent
Living Room Vent
Kitchen Vent

Is it possible that I had a channel/driver installed on my hub when the migration occurred and later may have inadvertently removed the channel/driver? In that scenario, would these devices have managed to “fall back” to the Zigbee Vent driver when I removed the channel/driver from the hub?

I see the driver selected in this case is the one from the default channel of SmartThings, not even the one in the Beta channel.
When the device is using a driver from a third-party channel we can see it in the system, so, it seems it doesn’t come from something you installed.
I already asked the team about this, I’ll let you know their feedback.

Hi @nayelyz, is there any news about my issue from the team?

Yes, so, during the migration process, the devices didn’t have their fingerprint info complete, this means another kind of match was done, and that’s why they migrated to “Zigbee vent” despite the fingerprint wasn’t present in the driver.
However, this doesn’t happen when you re-pair the device because this time the fingerprint info is present, and no match is found.
So, the team will add a generic fingerprint that should allow this and other vent devices to connect to the driver and get basic functionality.

This is the PR about it, it is still open, so, it can take some time to be reviewed:

If you need to reconnect the device now, you can download the driver yourself, add the device’s fingerprint and install it on your Hub directly

1 Like

Hi, @TylerDurden
Sorry for the delay. The PR I mentioned above was merged and it should be available now if you try to repair the device.
Can you confirm if it can be connected to the Vent driver again, please?

Hi @nayelyz,

I was successfully able to change the driver on the device to Zigbee Vent.

Thank you and the team!

1 Like

Thank you for the confirmation, we’re happy to help :smiley:

Hi,

I just bought a Keen Vent from Ebay, whose PN is SV01-610-MP-1.4
It double blinks green light but when I tried to add it to Smartthings, the ST hub could not see it.
Do I have to install the Zigbee Vent edge driver or add the fingerprint of this device before adding it?

Thanks.

I don’t think it’s a driver issue (yet). When you try to discover the device, it would still be detected as a generic thing if you had a driver issue. (Someone correct me if I’m wrong.)

Are you trying to pair it in close proximity to your ST hub, or have you already installed it away from the hub?

1 Like

I tried to add it when I was holding it about 4 ft from the ST hub.
It was blinking green light so it was reset, right?

From what I can tell, a double green flash means it’s in pairing mode. Do you have any other zigbee devices in your network? If so, how many and do any of them act as repeaters?

You could always try reseting the vent. I think 5 button presses should reset the vent, but I’ve experienced inconsistency with that in the past.

I assume you have brand new batteries and are using “scan nearby” to discover the device? Have you attempted discovering more than once? It may just take a few attempts. I know I had challenges discovering the Keen Bridge (not Vent), but it eventually worked.

1 Like

I used to have those vents. I think you have to press that little black button 10 times maybe? It’s been too long for me to remember.