Filtrete 3M-50 Wi-Fi Thermostat. Version 2.0 Released 12/17/2016

thermostat
communitydevices
dth_hvac

#162

Yes. If you use multiAttributeTile in your DTH:

		tileAttribute("device.thermostatSetpoint", key: "VALUE_CONTROL") {
			attributeState("VALUE_UP", action: "setLevelUp")
			attributeState("VALUE_DOWN", action: "setLevelDown")
            attributeState("default", label:'${currentValue}°')
		}

        tileAttribute("device.thermostatSetpoint", key: "THERMOSTAT_SETPOINT") {
            attributeState("default", label:'${currentValue}°')
        }

Should end up looking like this:


(Joe) #163

Thx.
That’s what the tile looks like for me too!

My issue is that there I don’t see thermostatSetpoint for this device- only heatingSetpoint and coolingSetpoint.
I’d like to be able to use the thermostatSetpoint variable in a webcore piston.

This is a snap of what I see for the device using this DHT with the wifi module. There is no {thermostatSetpoint}. :frowning:

snip11


#164

After posting this last night I started playing around with mine, and checking up on documentation. Unfortunately it’s not a variable ST supports within the multiatributetile for thermostat, but I’d think that variable would be available in webcore. I don’t use it (yet) to know for sure, so try posting your question in the main webcore thread?


(Jason Lari) #165

Hey everyone, I really need some help with this. I specifically purchased a SmartThings hub so I can control this thermostat with Alexa. I purchased a Alexa Enabled Thermostat and for a while it worked fine but I hated it because of its lack of features (specifically logging of the temperature and runtime). I put my 3M-50 back in and still love it however I have followed these instructions to allow it to work with the SmartThings hub but nothing I do will work. No matter what, it never finds my thermostat and updates the Device Network ID from the random one I put in. I have deleted the device and the device handler several times trying to make this work but it never updates the device ID and I am at a loss.

When I go into the SmartThings App (the new version…I cant use the old one because I activated the hub on the new app I think), it always shows my thermostat status as “Checking status…”. I cannot enter it to refresh or anything since it does not seen the device yet.

I have tried to check any log I can find for a Device Network ID but so far nothing. I am at a total loss. Any thoughts?

Update: Forgot to mention that I am using the Wifi Module although both Z-wave and Wifi are installed. I can poll the API manually from my browers and it all works fine with the Native Radio Thermostat App. I know it is setup right and working on my network, for what ever reason, it cannot be found by the ST Hub/Device Handler.


(Eric) #166
  1. does the Filtrete native phone app work with your Tstat? NOW I see you answered yes.

  2. there is a Samsung phone app, that you cannot/should-not use until you are specifically INVITED to do by ST support . But I assume you are using the old-but-updated-ST-native-phone-app (so am I) which does allow you to use custom device types such as your Wifi Tstat.

  3. you are familiar with installation of gecko’s Wifi custom device type? My old Wifi integration still works, I assume the custom device type has not changed. I am on hub v1.

  4. you are familiar with ST IDE? Check your cut-and-paste action, it’s easy to lose a character or 20 lines.

  5. consider uninstalling Zwave module (USNAP). I do not know how. I am not using Zwave module.

  6. there is only one place to see “Device Network ID”, right? IDE Device list.


(Jason Lari) #167

Thanks for the help, I removed the zwave which did not help. After some more exploring I found a page with configuration info that was not included with the setup steps. I am not sure if it was required but the moment I put in the IP Address, Port, and Polling Interval manually in the device config, everything started working and the device network ID populated. If this step is required, why was it not included in the instructions? Below is a screenshot I took of what I’m talking about


(Jason Lari) #168

Thanks again for the help. While it seems to finally be communicating with the SmartThings Hub and getting updated when its polled, for some reason it is not working with the SmartThings iOS app (Samsung Version). In the attached screenshot, you can see it just says “Checking Status…” still. I figured this would go away once I got it working but it is still doing it. Any thoughts?


(Eric) #169

I use the android app which I think is the primary interface to update the name, address, port, polling.

I don’t look at the thermostat with the phone app anyway, but it is updating.

Looks like live data. Did you try it with Alexa now.


(Eric) #170

at 21:03 on Jun11, my thermostat received an unrequested cooling setpoint change to 35F, for one minute. Pretty interesting - I noticed the fan should not be running. I suspect I can’t even set this low setpoint at the physical device.

Recorded by the tstat-manuf-app, but not ST, so this one does not look like an ST latency ghost command. Besides, I never sent any request for 35 ever, so ST has no record to ghost an old command.

Still, them’s the risks - I dunno - save your packet logs.


#171

I have the same problem. Online ST shows I am connected. My iPhone using the new ST app only says “Checking Status.” I am also connected to Amazon with an Echo and it has connectivity to the thermostat so I know the ST Hub is connected to the thermostat. The issue is with the 2nd gen (new) ST app.
Any help would be appreciated.
jalari, did you ever get your set up, the same as mine, working and if so may I ask how?

D


(Jason Lari) #172

So I finally gave up on the newer Smartthings app. It seems that this method is not compatible with it. Once I went back to the older version of the app (The non-Samsung Account version) everything works perfectly. I do not know of a way to make it work with the newer app. It most likely need to be adapted for the newer app and who knows if or when the author of the code will be able to do that.


#173

Thanks for the quick reply. I think I’ll go to the old app as well.