Fibaro Smart Implant

Does the switch change state in the app, or does it spin and just stays off?

Just spin and stay in current position. It was on this time when it froze. I do not remember if it was on or off the last time it froze.

Ok, here are a few things to look at so we can debug this:

  • I added some debug logs in fibaro-smart-implant.groovy and fibaro-smart-implant-switch.groovy, please update those files.

  • On the device page for the switch does it show the implant as the “Parent Device”?

  • What is the “Device Network Id” for the switch? It should be in the format 3B-switch-2, where 3B in my case is the network id for the implant.

  • Go to the Live Logging section in the IDE and see what is being logged when toggling the switch. Here is what I have:

4b25db56-9269-481f-864f-35b748cf14e8 1:03:18 PM: debug Implant Switch OFF '3B-switch-2'
e6adf403-1ef2-4444-ad3e-90a1247aec9d 1:03:19 PM: debug Implant Switch Commands: [MultiChannelCmdEncap(destinationEndPoint: 6, parameter: [0], sourceEndPoint: 0, command: 1, commandClass: 37, bitAddress: false), MultiChannelCmdEncap(destinationEndPoint: 6, parameter: [], sourceEndPoint: 0, command: 2, commandClass: 37, bitAddress: false)]
e6adf403-1ef2-4444-ad3e-90a1247aec9d 1:03:19 PM: debug Implant Switch Toggle, ID: '3B-switch-2', State: 'false'
4b25db56-9269-481f-864f-35b748cf14e8 1:03:18 PM: debug Implant Switch OFF '3B-switch-2'
  • I added some debug logs in fibaro-smart-implant.groovy and fibaro-smart-implant-switch.groovy , please update those files. - Done

  • On the device page for the switch does it show the implant as the “Parent Device”? - Yes, Fibaro Smart Implant is parent.

  • What is the “Device Network Id” for the switch? It should be in the format 3B-switch-2 , where 3B in my case is the network id for the implant. - 11-switch-2 is my child adress

  • Go to the Live Logging section in the IDE and see what is being logged when toggling the switch. Here is what I have:

e4f90418-22d1-4788-84fd-5e243478b826 12:48:58 PM: debug Implant Switch OFF ‘11-switch-2’

35cf2a4f-b78d-4b20-a24a-d727f481c558 12:48:59 PM: debug Implant Switch Commands: [MultiChannelCmdEncap(destinationEndPoint: 6, parameter: [0], sourceEndPoint: 0, command: 1, commandClass: 37, bitAddress: false), MultiChannelCmdEncap(destinationEndPoint: 6, parameter: , sourceEndPoint: 0, command: 2, commandClass: 37, bitAddress: false)]

35cf2a4f-b78d-4b20-a24a-d727f481c558 12:48:59 PM: debug Implant Switch Toggle, ID: ‘11-switch-2’, State: ‘false’

e4f90418-22d1-4788-84fd-5e243478b826 12:48:58 PM: debug Implant Switch OFF ‘11-switch-2’

The logs show that your devices are configured correctly and the hub is sending the z-wave command to the implant. Your issue seems to be the same as the one discussed in the Fibaro Forums (no solution).

Try adding the Switch 1 child device so we can see if that one works without any load connected to it.