Fibaro roller shutter 3 integration problem


I’m new to ST. I’ve included the device handler of @philh30 but when I try to “add thing” the device is not recognized. How do I know if the electrical connection was correctly done? I see the manual and it looks like everything is ok and the manual buttons are working just fine.

How can I do to find the fibaro? The hub is ± 10 meters away.

Can anyone help me please?

I bought the Fibaro Implant and Roller Shutter last year, i implemented the Implant but not the Roller Shutter yet. The implant took a bit of playing around to get it working and ended up using a Device Handler from @ovidiu.pruteanu which worked great.

I could try the Roller Shutter tomorrow to see if I can get it working if you have no joy?

Thank you @levanterman.

I finally found my Fibaro Roller Shutter 3, i just wanted to check, did you get this working ?

Hello, thanks for your feedback.

No, still cannot find the device… how did you made it?


I just tried it and connected it to Smartthings OK.

  1. Cycle the power on the Fibaro Roller Shutter 3
  2. In the Smartthings App , press + (to add new device)
  3. Select ‘Device’ from the options of ‘What you would like to add’
  4. Select ‘By Brand’
  5. Select Fibaro
  6. Select Switches and Dimmers
  7. Select Fibaro (the only option available in the UK)
  8. Press Start
  9. Select the Room you want it to be configured in Press next
  10. Press the Recessed Switch 3 times rapidly on the back of the Roller Shutter, a green LED should start to flash
  11. It will now be added to Smartthings, give it a name
  12. You will see Device appear in the Smartthings App
  13. Moments later you will see a second device Z wave device appear, this is your roller shutter switch. Its listed as ‘Z-Wave Device Multichannel’

You can press the on / off and hear the relay in the Roller Shutter momentarily turn on/off