Fibaro Roller Shutter 2 - FGRM-222 (DTH in post 24) (UK Device)

There is a new DH for fgr-223 here
Working great for me

1 Like

Hi @julbmann I’ve just got round to testing your updated dth from January 9th and I like the changes, it’s much snappier and responsive to changes. BUT I’m having an issue when using the physical toggle switch, the switch works but doesn’t sync the new status in the app. I tried looking at the code to see what changed with physical switch commands but it’s tricky to find the exact code responsible, so stuck using your older dth from last year. In Live logging when I toggle the switch I just get…

8f24d894-d145-4d3c-bd76-32d6732d0e5a 08:57:14: debug Couldn’t zwave.parse zw device: 6A, command: 9101, payload: 0F 26 03 02 00 00

8f24d894-d145-4d3c-bd76-32d6732d0e5a 08:57:14: warn Exception ‘java.lang.NullPointerException: Cannot invoke method parse() on null object’ encountered parsing ‘cmd: 9101, payload: 0F 26 03 02 00 00’

8f24d894-d145-4d3c-bd76-32d6732d0e5a 08:57:14: debug parse zw device: 6A, command: 9101, payload: 0F 26 03 02 00 00

(Pressing “Refresh” tile after toggle switch updates app correctly but impractical)

I did a small fix that correct this issue in my installation. you can download it here

But On my installation I don’t have the same error in my log so I hope it will also solve your issue. Let me know.

Hi Julien, thanks for the swift update. Edit. Got there in the end, much improved DTH, more responsive, well done! :+1:
And thanks to @philh30 for some invaluable guidance, both you guys rock!

i wonder if this dh or another works whit this product,searchweb201602_6_10065_10068_319_10059_10884_317_10887_10696_321_322_453_10084_454_10083_10103_10618_10304_10307_10820_10301_10821_537_536_10902,searchweb201603_51,ppcSwitch_0&algo_expid=c2296e94-db4f-4e87-bdc1-e3e2b85426bb-0&algo_pvid=c2296e94-db4f-4e87-bdc1-e3e2b85426bb&transAbTest=ae803_3

it’s a lot cheaper

My ST classic app on my mobile still cannot detect the Fibaro RS 2
I use the Fibaro-22 DH and added a new device but its still not working

I tried the same DH on the 6 other Fibaro RS2 and they worked.
Tried the reset the RS2 but it had a RED light meaning its unable to detect the ST Hub?
Any help is appreciated

I have installed the latest DTH dated 13th March 2019 however I can’t change parameter #50 (scene activation)… am I missing something?

Thanks in advance!!

Hi @julbmann
I have installed your DH and it works ok. The only issue I am having is the ability to associate my button controller to the Roller shutter. I belive this is due to the Roller shutter having the network security level at ZWAVE_LEGACY_NON_SECURE and my button controller (and the rest of my zwave connnected stuff) having ZWAVE_S0_LEGACY!
Is the non-secure inclusion a limitation on the FGR-222 or have I done something wrong? I have 11 FGR-222 and all of them have been includes as non-secure.

Thanks in advance

Hey all - new to smart things -

Is there a way that the FGRM-222 can be launched locally? i am worried about internet / cloud crashing

Yes and no! If you have hardwired your switches (S1 and S2 input in the reley) OR you have associated the Roller Shutter to a button controller, you will be able to control your blinds without internet connection as those two methods are independent of the hub.
If you havent, you will be stuck controlling your blinds thru the hub (automations or direct with the app) and if your internet connections is down you will not be able to control your blinds.
Hardwiring your switches is the preferred solution/option for local control as you can see from above post I am having problems associating my blinds due to security implementation in ST

@julbmann Hi, any way to stop all the “debug” messages going to the hub every single 7 minutes? Seems like unnecessary chatter on the network. I see no way to set logging to false…


Since few months, I noticed that my Fibaro Roller shutter devices (fgr-222) connected to my V2 UK Hub started suddenly operating randomly (eg opening without an Open order when being closed). I have 4 of these devices and they dont all open together. I noticed that randomly one of those devices open up, and then suddenly another opens up. It might be happening on power reboot of those devices, but not consistently after every power reboot, and this didn’t use to happen before .

Any help on what might be happening here ?
I’m using Julien’s DTH, and it works great. Just that this recent strange behaviour of the device by itself , especially when not moved for a while


Agree! I have 10 modules and that creates a lot of traffic…

Hi @julbmann,

Just updated your DH but something strange happened. I lost the schedule in the new app, and also the energy consumption and power meter boxes. Do you know why? I noticed that the icon is now a blind, thanks!

By the way, it works also with the new model FGR-223.

Thanks for your work!


Mine shows as 254%. When I press close the motor keeps going until it brakes the roller brackets. Any ideas?


I am using your device handler for quite some time. it works perfecly. A few weeks i sarted to use the new ST app and it works fine but it does not show if it is the shutter is open, close ou partial. Can you help?

Best regards

Hi @julbmann ,
I’m facing the same problem as @RAST2016. Everything works in classic , I can control my shutter in the official app. The status of the shutter in the official app is always :
“Checking Status”
Any ideas how to fix that ? Reminder , in 14 oct. the classic app is going to sunset…

Unfortunately I have absolutely no time to spend on this device handler. But the code is open source so anybody can have a look and modify it to support the new application.

What I did on my installation is that I switch to the default z-wave window shade device handler. It is working well in the new application. It has less feature but it works well.

Sorry that I cannot continue to support this device handler.


Thanks @julbmann
Z-wave window shade local handler worked for me as well, no more “checking status”. I was needed to switch between Q1 and Q2 wiring in order to make it work as in yours handler. I prefer your handler , but this is a good workaround.
I hope you’ll find time to adjust your handler to the official app. I don’t understand programming code at all… :slight_smile:
Thanks for your advise. :pray:

Update : also needed to replace S1 and S2. Everything works as in your handler

I’m using the device handler to the FGR-223 of @philh30 with my devices FGR-222 and FGR-223 and they are acting equal.