Fibaro Roller Shutter 2 - FGRM-222 (DTH in post 24) (UK Device)

Hi,

I have recently bought a Fibaro Roller Shutter 2 z-wave connector and I am trying to pair it with my smartthings v2 hub but without success.

Can you please help me on how I can make the Smartthing Hub detect my Fibaro Roller Shutter 2 (z-wave module) ?

The version of the Fibaro Roller Shutter 2 - FGRM-222 is 2.5.

Thank you.
Daniel Duarte

1 Like

I have the same problem, no detection at all…

Are you using the backend or the app?

Hi @Sergio_Ferreira

I’m using the Mobile App in order to activate the ST Hub into search mode (Add Thing).

Should I do it in a different way ?

Thank you.
Daniel

Try using:
https://graph-eu01-euwest1.api.smartthings.com/login/auth
That way you can define your own device handler from the list…

Let me know how it went…

Hi @Sergio_Ferreira,

Right now I’m not at home so I cannot test it right away, in the meantime I was checking the page and can you please tell me what should I put in the Device Network Id filed ?

Also there is no Fibaro Roller Shutter on the list of devices, should I add it as a Dimmer ?

Thank you.
Daniel Duarte

My few cents…
If I recall correctly I don´t put any real value there or a dummy one.
I would try the dimmer option…you can change it if it not works.

Take a look to: FAQ: Fibaro FGS 222 Relay - Installation Guide / How to for beginner

You need to add a Device Network Id, it is a mandatory field.
I´ve created a device handler as Fibaro dimmer but now what do I need to do, still no detection.

Does anybody have a custom code?

OK, update. After creating the device handler I got it connected.
Tried on the phone app, clicked B button three times very fast and I got it.

I will on the weekend connect to one of the roller shutters and try to calibrate.
Now if I change “percentage” I hear a click for a few seconds. Now sure now if it does up and down switch of if if closes only one of the outputs.

Hi @Alex_fonseca,

I’m still having problems in finding the device. Can you please tell me which device handler did you install ?

Thank you.
Daniel Duarte

I´ve created a “Create New Device Handler” and then selected “From Template”, then selected on the Templates “Fibaro Dimmer”.

I am not sure it is going to work. I only have the options "ON/OFF and then percentage, so how can I select up/down value to close 2 outputs, I am not sure…

Hi @Alex_fonseca,

Thank you for your input. I have created a new Device Handler as you state but I still cannot identify the device. I will be doing some more test and update on this thread.

If anyone as more hints on how to make my device detectable please let me know :slight_smile:

Thank you.
Daniel Duarte

take a look:

:grin:Just to let you all know I got mine to work, opening and closing fully only.
% does not work but I can do automated sequences like close blinds at sunset.

I am going to buy 5 more and I will try to get the full description how to do it.

I’ve changed my device to “Fibaro Dimmer” and now I can get to close to percertages.
THAT IS GREAT!!! It Works 100%.

So I can confirm Fibaro Roller Shutter 2 is working 100%.
Just one note I have FGR-222 with firmware 2.5 not FGRM-222.

2 Likes

Hi,

I have finally found the reason for not being detecting the FRM222. I had bough the Smartthings Hub on the US and the FRM222 on Europe. The z-wave frequencies are different depending on the region and this was the reason why it was not being detected at all.

Now I have finaly managed to detect and install as the Fibaro Dimmer which is working quite fine. The only problem is that the dim is not properly calibrated. When the blinds are all open I get on the fibaro dimmer bar around 20% and not 0% as expected. The dimming bar is always around 20% away from is real value (half of the blinds open represent on the “Fibaro Dimmer” dimmer bar around 70% and not 50%.

Does anyone knows how to calibrate this ?

Thank you.
Daniel Belém Duarte

Hi Daniel, wich fibaro you used then for the US Hub?

Hi,

I have bought a new HUB ok the UK which uses the same frequencies as in Europe.

Thank you.
Daniel

Hi Daniel, did you do the calibration of the Fibaro after connection.
Press Fibaro button for 3-6s until you get the blue light, temporarily release buton and press 1s again. It will do a full close and open and should solve it
Mine are working fine, only issue is 50% open corresponds to 50% motor rotation.
Since you have that period where the blinds are full down but not closed (they will start closing the small gaps between the rows), 50% means only real ~35% open.
But I can live with that.

1 Like