Fibaro Motion Sensor stuck on "motion"

Hi, I know it’s been a while since you posted, but did you find a solution? I’m having the exact same issues and could not fix them so far. :frowning:

Still no fix??

Since at least six months ago, every time that one of my four Fibdaro motion sensors detects any motion, it remain stuck in MOTION for hours or DAYS (unspecified time).

This is extremely irritating, since I use them to turn on lights when motion, and the light remains turned on until I use the SmartThings APP to turn it off. I can also see in the APP that the sensor remains in MOTION STATE.
This also defeats the purpose of using these sensors as part of the alarm system.

On the other side, my Smartthings Motion works perfectly. This leads me to believe that the issue in on the device handler or the Fibaro device itself.
I am so irritating with this, that I am thinking to replace all Fibaro sensors.

All my sensors are within a range of 10 meter from the Hub.

I’ve tried a combination of custom DTH, the standard Device handler, multiple factory resets and hub reboots with two new ZW5 motion sensors. Same issue with getting stuck on motion. Frustrating as the LUX reporting is fine…motion is not reliable.

I’m having the same issue with mine, settings modified using the custom DTH but then set back to the standard DTH for normal operation.

Battery is showing as 81%. Did anybody else have any luck when testing the z-wave range detector?

I’m getting sick of my sensors being stuck on motion. It makes them useless for anything in st.

Is it a battery issue or something more serious?

Anyone find a fix for this?

Never worked it out, one thing though at least for me is changing the batteries gets it working eight again, but that just means the battery drain is massive :joy:

Mine says 100% though lol

Interesting, mine would at least get to 90 before it starts getting stuck, change it anyway just to see if it makes a difference. Could be a battery brand thing!!!

I had the same issue with one of my sensors, which is located in my hall way.

I tried to adjust parameter 1 (Motion detection - sensitivity) from 15 --> 25 and 2 (Motion detection - blind time) from 3 to 15. My preliminary result is, that the sensor is no longer in an “ON” state … I will keep you posted should my result change.

Happy Z-Wave building :slight_smile:

1 Like

I’m seeing the same issue as above with my one and only Fibaro Motion Sensor (ZW5) - it detects movement on the device (it flashes) but only sometimes does a notification make its way to SmartThings, and when it does, the inactive notification often does not get captured. Tamper alerts (but not tamper clearances), temperature updates and luminosity notifications are captureed ok. The battery is still reporting at 100% (its roughly 1 month old). I took it out and put it back in with no difference.

I’ve just done a ZWave repair but that’s not made any noticable difference. I’ve tried both the standard ST device handler and the community built enhanced one.

Last thing to try is to repair with ST but wanted to see if others are also still have issues with this device. I’ve no issues with my SmartThings motion sensors.

Just a place holder until I find what I want to direct u too…I’ll be back :grin:

Interestingly, I wondered if this was a simple as a mesh network issue. I noticed that a ZWave power socket near the Fibaro occasionally became unavailable, so I wondered if that was acting as a repeater. I moved a few things about to improve the ZWave mesh between the hub and the Fibaro and, after a ZWave repair, things seems to fix themselves - I’m now getting all events reported again.

What this doesn’t explain is why tamper, illuminance and temperature notifications were getting to the hub, but the motion notifications were not. Could it be that some can go via repeaters but others only communicate with the main controller?

@Paralytic, that was the conclusion we came up with too. Check out the last few posts on this thread [RELEASE] Fibaro Motion Sensor ZW5 (ver. 3.2) (Advanced DTH) between @Levahj and myself.

For me I had an old ZWave socket that was no longer in use and by following the instructions on the other thread I noticed what hops were taking place. I did the repair too, which removed the socket and since then its better.

I wondered about why only some functions got stuck and not all, I guess there are programmed differently.

I know this is an old thread, but I’m experiencing the same issues. I have 5 of these Fibaro Motion sensors ZW5, and 2 of them randomly get stuck on “motion” (which confuses some webcore pistons). It happens 1-2 times/day. As soon as actual motion is detected they resume normal operation, followed by another “freeze” hours later.
I think I have a solid Z-wave mesh, with Fibaro dimmers placed 2-3 meters away from the motion sensors. Batteries are at 100%. I have run Z-wave repairs and reboots of my V2 hub. The 2 sensors acted the same way before the recent hub upgrade (they run local now). Any suggestion is welcome.

1 Like

I had this for a while with one of my Figaro ZW5 motion sensors. First thing to do is check the raw description in the IDE to ensure the initial connection was secure (starts with zw:S)

zw:Ss type:0701 mfr:010F prod:0801 model:1001 ver:3.02 zwv:4.05 lib:03 cc:5E,86,72,59,80,73,56,22,31,98,7A sec:20,5A,85,84,71,8E,70,30,9C role:06 ff:8C07 ui:8C07

In the end, I had to remove mine from the network, move it closer to the hub to reconnect it, and then reposition it to where it should go.

You could try a ZWave Replace first, but that never fully fixed it for me,.

Boiled down to a back mesh network, see my previous post, once i resolved that, they have been pretty good and solid.

@Paralytic - the raw description matches the one you gave for all sensors.

@KellyDarren - I don’t think it’s a mesh problem, I have repeaters everywhere. But just to make sure I moved one of the sensors right next to the hub. Nothing changed, the same occasional freezes occur. It gets stuck on motion and it stays like that (visible in ST classic and ActionTiles) until a real motion event is triggered. Then it gets back to normal.

Did you remove/re-add to network after physically moving the device? If not, that is unlikely to have made any difference.