Fibaro Motion Sensor - New device-handler with all settings and auto sync feature

Not trying to hijack the discussion from this awesome device type, but I am having a hell of a time including this device. Does anyone have any good tips?

Update: as soon as I posted this, I was able to successfully include it. It took me several inclusions and exclusions before it worked.

Try excluding it first then include it.

I cant seem to get the LED’s to turn off, I have set parameter 80 to LED Inactive but still they flash when they detect movement. Has anybody been able to successfully turn them off?

My sensor LED is turned off. I set 80 and 81 to zero, as well as 89. And of course, you have to wait for the changes to sync.

1 Like

Sorry if this was already answered and i missed it, I have my 5 Fibaro motion sensors set to turn on lights in dark rooms based on illumination of less than 5 LUX, i used this excellent IDE and am trying to get the LUX to report quickly as my issue is that it seems to take long for the Fibaro to send back the report when the rooms in question are light again, basically they would be in 0 to 1 Lux at night and when lights are on in the rooms or daylight arrives, they still report the LUX below 5 so lights are still turning on even though it s bright in the room. Then after mid day i get the higher Lux reading but by nightfall they are still reading the higher Lux preventing lights from turning on. i set the illumination threshold down as far a 1 to report change but still takes long. Any suggestions would be greatly appreciated. thank you

Sounds like its not polling that lux level on a regular interval. You might want to use pollster (I think its called that). Have a search, this basically forces the device to update its readings to the hub (as far as I’m aware?)

Found the thread:

Thank you deano12, i will take a look at that.

I adjusted the settings in my Fibaro to sample the lux more frequently. I believe the settings to change are:

  • Parameter 40 Illumination report threshold - Set mine to 50
  • Parameter 42 Illumination report interval - Set mine to 180

The p.40 is suppose to report changes in lux of 50 or more, but I find it reports pretty much any change within about 2-4 lux. The p.42 means it will report every three minutes – however, it only reports a change, so in real world it only reports that frequently when the lighting is changing (which is exactly what I wanted).

You might find this SmartApp helpful, it controls the lighting using dark and bright lux values.


Make sure the dark and bright lux values are a good 15-30 units apart, or you might get a flashing effect. Also make sure your Fibaro units aren’t pointed right at lamp.

1 Like

Thank you xcguy, i will try these :slight_smile:

I had my parameter 40 set down to 1 as my LUX readings seem to stay in the single digits inside the house with just sunlight in the room, unless i have really bright lights on then it goes into triple digits. Then my parameter 42 I left at 0 so will now make same adjustment to 180 and see how that works. thanks again.

Just my two cents, but setting p.40 to 1 I think will eat your battery up fast. At 50, it is still sensitive enough to report tiny changes down to zero (including the single digits), but doesn’t repeatedly report a single digit in change. Check your logs to confirm.

ok I will set to 50. i thought that if set at 50 it would not report if it went say from 10 to 4 where my setting is to consider anything under 5 LUX as dark, and thats based on what i see the sensor report when i consider a dark enough room to need light.

thanks

Folks, I am trying to configure 2 Fibaro motion sensors to work with my new SmartThings hub (v2).

I have copied the latest code from CyrilPeponnet and published it to my devices, that seemed to go ok. I have the devices connected to my hub and visible in my Android phone, the sensor is reporting motion and sending alerts to my phone.

I am unable to access the configuration menu. Not sure if this is relevant or not, but I am only able to view motion, temperature, acceleration, battery, lux and configure options. I do not have sync status, activity or smart apps tiles.

I hope this isn’t gibberish and someone can point me in the right direction to correct this.

Hi @fmttm,

Can you send a screenshot of the sensor status screen from your ST app? Sounds like it might be using the default motion sensor device type and not the custom device from CyrilPeponnet

Hello @adeparker,

I have attached a screen shot for reference although I no longer have an issue with the motion sensors. When I woke up this morning they were working with no LED indicators flashing, which is exactly how I want them to work. Now I will work on connecting the Sonos speaker that will interact with the motion sensors and smartthings hub.

Thanks for the reply.

After you have created the device type, you have to assign the device type to the actual device under “My Devices” in the IDE. Make sure you complete that step or the device will continue to use the default SmartThings device type.

Thanks Eric, I made sure I did that yesterday. I think I was just being a little impatient with the devices yesterday with being new to this system. Appreciate the advice!

Good to hear you got them working @fmttm. They’re a great little device and definitely worth the added time to set them up

This is a great addition! Appreciate the efforts in making these fully customisable.

Just got my fibaro sensor and had some issues getting it set up correctly as well.

Got it working finally by restarting hub before connecting, resetting sensor to factory, putting sensor right next to hub, pairing with the standard device type, leaving it a bit, then making all the changes (name, device type to this one) on the IDE. All suggestions I picked up from various threads - not sure which helped - but the combination worked for me :smile:

Nice work there @Yanwoo

I am now working on connecting the Sonos Play 1 speaker and having it play a mp3 file hosted on Amazon AWS. Easier than it sounds so far…

I have the smartapp configured in IDE, with the parameter for DOG BARKING set to the URI for the file located in the Amazon AWS. I have the smartapp configured to use the DOG BARKING action using the Sonos speaker I have configured. I see the sensor detect the motion, I see the log event indicate the event occurred at the same time it played the sound file, but I get nothing out of the Sonos speaker…sigh.

Anyone have any idea where I am going wrong or what additional information you need to assist me.

FYI, I have browsed to the file hosted on Amazon and can play it, so I know its accessible.

Cheers and Happy New Year!

FMTTM