Fibaro fgr-223 DH needed!

Not sure if anyone is having the same issue here - we have been using the FGR-223 with this DH to control blinds for residents with physical disabilities - they are using voice control via Amazon echo devices. However, the FGR-223s have stopped working across the board with Alexa earlier this week.

When using DH created by [philh30]:
The FGR-223s are working within the Smartthings app normally.
Attempts to control the FGR-223s (using the DH created by philh30)via an Echo device will result in the spoken “Ok” response from the Echo device, but nothing is actioned. The log, however, showed parsing of all the FGR-223s in the system after the voice command.
Attempts to control the FGR-223s (using the DH created by [philh30]) via the Alexa app will result in “The device is unresponsive” message on the app.

If Z-Wave Multichannel Device DH is used,
The device works in both Alexa and Smartthings app.
The device will respond to voice commands (turning on / off the blinds).

Followings have been tried:

  1. Power cycling the ST hub
  2. Rebooting the ST hub with the IDE
  3. Removing device from Alexa and then re connecting
  4. Excluding and reincluding the device from the Z-Wave network
  5. Repairing the Z-Wave network
  6. Setting up other hubs / accounts
    None of the aforementioned attempts appear to be able to get the FGR-223 to talk to Alexa when using the DH created by [philh30].

Just wondering if any of you might have pointers towards what to look for? I have contacted the Smartthings support and they were unable to offer much help as it is not a supported product, which is quite disappointing as it seems to be something between the interface of the DH and Alexa is causing the issue here.

Your input would be much appreciated.

I’m having similar problem. I can still control my window shutter via Alexa, but only to Open and Close. I can’t control to be open in a certain percentage. @philh30 Please comment , please give as the solution to properly control our windows shutter vial Alexa. It used to be OK.
@systema , did you follow the following steps when migrating to new Smartthings skill in Alexa:

WHAT WORKED :

  1. disable the skill (make sure the classic skill is disabled already as well)
  2. remove ALL devices (that came through smartthings) AND all rooms one by one from Alexa.
  3. re-enable the smartthings skill (you will have to log in again and connect accounts), which will re-discover all the devices.
  4. Then re-add rooms and devices to rooms.
  5. modify any routines that were using these devices and re-add them to the routines.

This came from one of the comments for Alexa Skill.

@dotan_shai, I tried the same procedure you have outlined on a freshly set up hub and a new Smartthings and Alexa account just in case it is other devices in the system that is causing the issue - didn’t seem to help though.

I am currently using a virtual switch (with automation routines) as a work around as Alexa is working with virtual switches, but, from my perspective, something is certainly broken between Alexa and Smartthings in the new Smartthings skill.

Hi ! It worked awsomely EXCEPT…

When i click the physical switch it does ot update on the app (like it does for light with walli dimmer)

Dont you have the same problem? It would be AAWWSOOMME to have it solved

Well I’m struggling a bit with this but it’s the first time I’ve used Fibaro.

I have a fairly standard garage roller shutter door that was connected to a radio receiver which I’ve disconnected. It’s a 4 wire motor - up, down, neutral, earth. I’ve proven direction with a manual switch and it cuts out automatically on it’s upper and lower limits.

What should the operating mode in parameter 151 be for a roller shutter like this? It’s a garage door so I’m only ever going to want it open or closed. Do I have to set it as a blind or a gate and do I have to calibrate it? I’d like it show as open or closed in the app. The problem I’ve had is that after having it going fully up and down both from the app and the momentary retractive 2 way switch, it just seemed to lose the plot and start only moving for a few seconds before showing that it was open or closed.

Any help or advice would be appreciated

Also having a problem. There is no way to set and save parameters in the Official SmartThing App. I want to change the Switch Type (parameters 20). I am able to set it in IDE or in he app but NOTHING actually happen in the module.
I found a workaround by installing an old version of SmartThing Classic App, that helped. But not anymore. Classic App always showing “Something Went Wrong” in My Home tab. What to do ? How to set and save the parameters.
Can someone please help ? @philh30 can you please comment…

@dotan_shai,
I have two Fibaro FGS-223 double switch with the original DTH “Fibaro Double Switch 2 ZW5”, they work fine with the configuration changes from the app.
I think the configuration code in DTH for switch tipe in FGS and FGR will be same.

Thank you @Mariano_Colmenarejo,
I’m refering to FGR-223 , Roller Shutter. For that there is no Build in DHT.
I’m using @philh30 handler , which works but i can’t save pararmeters.

1 Like

Aren’t you able to use Z-Wave Tweaker to change the parameter then either change the dth back or to the inbuilt Z-Wave Window Shade dth?

What happens in live logging when you change that parameter in the IDE and save or change it in the new app settings?

When I just tried, I saw both methods post logs showing it’s trying to send the updated config to the device. Of course, I don’t have this or any other Fibaro device, so it’s tough for me to troubleshoot.

This is what i’m getting when changing parameter 20 to 0 and to 1. I’ve bold the 1 and 0

1761122d-9d19-45d7-9540-eb7366cf4a37 11:13:54 PM: debug Send configuration parameters [7004140101, 700514]

1761122d-9d19-45d7-9540-eb7366cf4a37 11:13:54 PM: debug Sync roller shutter - Shade state: partially open; Shade level: 56

1761122d-9d19-45d7-9540-eb7366cf4a37 11:12:58 PM: debug Send configuration parameters [7004140100, 700514]

1761122d-9d19-45d7-9540-eb7366cf4a37 11:12:58 PM: debug Sync roller shutter - Shade state: partially open; Shade level: 56

Based on those logs, the DTH is accepting your parameter changes and sending them to the device. However, you should be seeing a “configuration report received” line in the log right after that to indicate that the device actually received the parameters. If you change the level of the shade through the ST app do you see any reports post in live logging?

Exact same issue here. My roller shutter does not seem to take into account any of the parameters changes I’m trying to update.

My logs are here
4fdcfeae-c84b-4895-882c-2d1233f4c0f7 15:15:12: debug Synced - Shade state: open; Shade level: 99
4fdcfeae-c84b-4895-882c-2d1233f4c0f7 15:15:03: debug Send configuration parameters [7004140101, 700514, 7004990100, 700599]
4fdcfeae-c84b-4895-882c-2d1233f4c0f7 15:15:03: debug Sync roller shutter - Shade state: open; Shade level: 99

And I do get a log when I change the shade level in the ST app.

I’ve installed a very old SmartThings Classic App. I was able to Set the parameters with that version. What I’m getting there when setting parameter #20 to 1 is:
21e7b3b8-6701-4a34-8033-100f129faeec 9:18:12 AM: debug New event to parse: zw device: 1D, command: 3202, payload: 21 32 00 06 00 00 00 00

21e7b3b8-6701-4a34-8033-100f129faeec 9:18:12 AM: debug Synced - Shade state: open; Shade level: 100

21e7b3b8-6701-4a34-8033-100f129faeec 9:18:09 AM: debug Send configuration parameters [7004140101, 700514, 70043C0101, 70053C]

21e7b3b8-6701-4a34-8033-100f129faeec 9:18:09 AM: debug Sync roller shutter - Shade state: open; Shade level: 100

And everything works. I think command 3202, do the “trick” but i’m not sure. I always see command 2603 when updating status.

Which old version of smartthings classic app did you use ? I tried several ones but everytime it reverted me back to the new app.

Ok I found a working classic app (which by the way is so much more reactive and simple that the new one…), but it’s still not working for me. My logs are still the same as before too.

Hey, few weeks ago my google home& assistant stopped integrating with fibaro roller shutter 3.
I can see the devices in google home as blinds, but cannot use any of them , not from the Google home app, and not from the voice command.
I use the fgr223 handler, which as I said worked fine for a few month.
Unlink/link didn’t make any change.
Please need your help.

Hi, I have the same problem since 1 year ago (when smartthings app updated and we had to relink the account). I didn’t find any solution, do you have any news?
Ty

OK. I found how to configure Fibaro Roller Shutter from the official app. using Z-wave Tweaker. This is a walkaround until someone will fix @philh30 current DHT.

  1. Temporary change the device handler to Z-Wave Tweaker.
  2. using the official app go to your device settings which should look different this time.
  3. Set parameter #14 for FGR-222 or #20 for FGR-223 to 1 for toggle switch or 0 for momentary switch.
  4. Check IDE live loggings to see that the parameter have been send successfully.
  5. Check your roller shutter. It should behave as configured
  6. Change back the Device Handler to Fibaro FGR-223.

DONE , Roller Shutter is properly configured from the official app. Hopefully someone will fix this Device Handler so no walkaround should be used.

1 Like