SmartThings Community

Fibaro dimmers wiring question (UK)


(Roger Dunnaker) #1

Hello following the invaluable help from Robin I installed a test Fibaro dimmer with load module this morning, installed at the switch as per the drawing from Vesternet with live wire to L on dimmer, common from switch to SX on dimmer, L1 from switch to S1 on dimmer, a loop from N on dimmer to the arrow through the sine wave on the dimmer and the switch wire to the light fitting also to that terminal on the dimmer. At the light fitting I have the module across the live and neutral.
The LED lamp is still flashing, can anyone see if I have done anything wrong or suggest a fix?

Many thanksUploading…


(Robin) #2

Can you post a link to the vesternrt diagram you followed please


(Robin) #3

The loop should be between N and Sx not N and Load (arrow through sine wave as you put it).

Not sure if this would cause the flashing, I’m surprised it even turned on!!


(Roger Dunnaker) #4

I hadn’t found a diagram showing wiring for the 212 so I assumed that the arrow sine wave symbol was the same as 0 on the 211 which looked like the live to the lamp at the ceiling rose

Roger Dunnaker


(Robin) #5

The 211 required a neutral wire (3 wire system). It is a very different device compared to the 212 and has a very different wiring layout.

Wiring instructions come in the box with the 212:

Also here:

Hopefully you haven’t fried your module…


(Roger Dunnaker) #6

Thanks for that, finally got it to turn on and off at the switch, it will not dim and although it’s showing in smart things, it is not being controlled by smart things, any ideas?

Roger Dunnaker


(Roger Dunnaker) #7

Be just my luck if I have!

Roger Dunnaker


(Robin) #8

You will need to install a custom DH in the online IDE, suggest this one:

Guidance on how to do this can be found here:

Let me know if you are still struck.


Fibaro dimmer 2 with toggle light switch
(Robin) #9

If memory serves, you are using the original toggle switch right?

If so, you won’t have dimming ability at the switch.

Dimmer 2 modules work best with momentary / retractive switches.


(Roger Dunnaker) #10

No,I had delivery of momentary switches this morning so have installed one of them on that circuit. I have absolutely no idea what an ide is or how to change it, do you mean on the dimmer or the smart things hub?

Roger Dunnaker


(Roger Dunnaker) #11

Well, I’ve read that and didn’t understand a single word, i am a retired spark, I’ve forgotten most of what I used to do and have little or no interest in computers, so help please!

Roger Dunnaker


(Robin) #12

Have a good read through the FAQ above.

The relevant section fur you is:

USING A CUSTOM DEVICE TYPE HANDLER

The IDE is the Smartthings online portal where you can install custom smartapps and device handlers.

https://graph.api.smartthings.com/

More detail in the FAQ but:

Copy the code from the GitHub link I posted
Log into the IDE, go to locations and click on your home location (it will ask you to log in again)
Go to device handlers tab
Click new Device Handler
Click from code
Paste code
Click OK (or it might be ‘done’) at the bottom
Click save at the top
Click publish > for me
Go to the devices tab
Click on your Fibaro Dimmer
Click edit
Change type to match the new DH you saved above
Save and you’re done


(Robin) #13

What part of the U.K. are you in?

Maybe I can help if you’re not too far away?


(Robin) #14

So, after over 20 odd private messages between myself and @Rogerdunnaker he has a working system :sunglasses:

He wasn’t sure how to setup custom code so he instead trusted me with his IDE credentials. I logged in and setup his Dimmer 2 with the custom device handler by @hajar

This gave him ST control but he was still getting a flashing lamp even with the bypass module fitted.

I checked his wiring photos and it was all spot on.

We unsuccessfully played around with the auto calibration and trailing / leading edge parameters.

Turned out he didn’t have a dimmable lamp and the auto calibration was not detecting the lamp type like it should - maybe the low wattage of the LED lamp?

He swapped over to a Dimmable lamp, forced a calibration (using parameter 13 set to ‘2’), and all working perfectly now.

As a side note - if he wanted to use the dimmer 2 with a non-Dimmable lamp he would need to set parameter 32 to ‘1’ which disables the dimming function.


(Robin) #15

@Rogerdunnaker

If you chose to buy any more Dimmer 2 modules beyond this trial unit, let me know and I’ll help you with the IDE part again.

Now the DH is already installed, it’s a much easier process for future additions.

For now, don’t forget to change back to your usual password!!!