Fibaro dimmer 2 not reporting status


(davechudley@gmail.com) #1

Hello all,

Firstly I’d like to say that I’m brand new to the HA scene, I’m an electrician, I’m fairly savy with tech and trying to break into HA (especially lighting at first). So please forgive me if im asking silly questions.

I have purchased the ST hub aswell as a couple of fibaro dimmer 2s (got the dummy load as well - bypass 2) and finally some retractable switches.

The lamps/bulbs I’m using are LED 7w x5 therefore i assumed id need the bypass, however they dimmed fine without. Am i missing something?

Im finding that the ST app is not reporting the state of the lights (says always - on ) but they seem to work fine, dimming and no flickering. Is this normal for this app?

Forgot to mension that i have no neutral at the switch so is wired in the 2 wire method.

Thanks for any help.
Dave.


#2

Have you logged into the ide and made sure that you have enabled the z-wave module inside the st Hub?


(Robin) #3

You need to install a custom device handler for the Dimmer 2… the default one is old and relates to the original dimmer.


(Robin) #4

Regards the lack of flickering… it’s sometimes pot luck and depends on the quality of the LED’s.

Below 50w without the bypass you’d expect to see a very slight glow in one of the lamps when turned off…


(davechudley@gmail.com) #5

@Baz2473
IDE? Sorry i have no idea what that is :confused: however i have the functionality in in the ST app and they are paired so zwave must be enabled, right?

@RobinWinbourne
Custom device handler, i’ll try and figure out how to do that. Is it web based or in the ST app?
The lights dont glow at all. Completely off. Does the bypass have any other use? (Allow functionality in any way)

Thanks again.


(Robin) #6

The bypass has two functions… prevents glow when off (for two wire installs) and prevents flicker in some setups.

If it’s working without glow or flicker then save the bypass for a different circuit… it adds no functionality in itself.


(Robin) #7

(davechudley@gmail.com) #8

Thanks for the link. Enlightening.
I have also done the tutorial for github. Things are making a lot more sense now!

Re bypass; thats what i thought, thanks for clarifying.

Now to add the CDH :grin:

Thanks for the help, really appreciate it.


(davechudley@gmail.com) #9

So, I have this; (see attachment)

But can’t see ‘my apps’ in the ST mobile app, its ment to appear in
marketplace as far as im aware.

Feels like a up hill struggle, the IDE sometimes says i dont have devices
or even a hub! Bit buggy. But hopefully nearly there, first one is always
the worst… right? :blush:

So how do i get ‘my apps’ to show in the mobile app? What am i missing?

Thanks in advance.


#10

That’s a Device Type Handler that you’ve added. Not an app. You need to select the devices tab. Then select the device that you intend on using that DeviceTypeHandler with and then select edit. You will get a list of info for that device come up and there will be a drop down list for selecting the DeviceTypeHandler you want to use for that device.
Once you have selected the new DeviceTypeHandler (it will be at the very bottom of the list) save it. Then you should have full functionality of that DeviceTypeHandler for the device you wanted to use it for.

Sounds daunting but you do get used to it very quickly.


(davechudley@gmail.com) #11

@baz
Thank you!! All sorted now, worked a treat.

Thanks guys, would have struggled like hell without both your advice.

Dave.